Prologic + MasterTemp 400 Please help!

Izhe13

In The Industry
Sep 20, 2022
5
FLORIDA
Hello, I have my Pentair MasterTemp 400 connected to my Hayward Prologic board via the 2 wire method (18AWG per spec)

Fireman Switch to the Heater1 relay on the Prologic

I have enabled heater1 in the configuration menu on the ProLogic. I press heater1 and no light illuminates and it says Gas Heater Auto Control and no response from my MasterTemp 400.

When I remove the 2 wires and connect the jumper at the fireman switch the MasterTemp 400 immediately works. I used a multimeter at the Prologic to ensure I am receiving voltage and continuity. I am indeed getting around the 24VAC per spec and continuity.

Any ideas on resolving would be greatly appreciated
 

Attachments

  • D65ED6FE-BA47-48A3-8927-284CA19AB7CA.jpeg
    D65ED6FE-BA47-48A3-8927-284CA19AB7CA.jpeg
    521.9 KB · Views: 6
  • 9AE8D29B-1B52-4E25-AAEB-E02075BC2073.jpeg
    9AE8D29B-1B52-4E25-AAEB-E02075BC2073.jpeg
    346 KB · Views: 5

1poolman1

In The Industry
Jul 14, 2014
3,157
Sacramento
When you turn the heater on at the ProLogic, there should be continuity between the two terminals labeled "Heater 1 Relay." Is that what you have? Test with the wires removed. If so, the ProLogic is working correctly. Be sure both wires are stripped clean and completely inserted into the terminals. Before doing that, with the wires removed, twist them together and see it the heater lights. If not the problem is in the wiring. Also, what is the water temperature reading? If the water temp sensor is bad the ProLogic won't allow the heater to light. You usually have to be in service mode to manually light the heater from the ProLogic, or take it out of "auto control" in the menu.
 

Izhe13

In The Industry
Sep 20, 2022
5
FLORIDA
Thank you for the feedback everyone I was able to resolve this by using this guide from Hayward. The heater was working in service mode and as soon as I set the pool and spa to 104F on the ProLogic and exited service mode it worked.
 

Attachments

  • Screenshot 2022-09-20 at 1.36.41 PM.png
    Screenshot 2022-09-20 at 1.36.41 PM.png
    209.8 KB · Views: 4

Izhe13

In The Industry
Sep 20, 2022
5
FLORIDA
I can adjust the heater itself manually and then toggle between the spa and pool. If I change the ProLogic temp the heater function stops entirely. Can anyone confirm if this is ProLogic's intended function? Being able to set comfortable pool/spa temps on the Prologic and not have to think about it would be great!
 

Izhe13

In The Industry
Sep 20, 2022
5
FLORIDA
Here are the instructions from the manual on setting up heater operation for a Pro Logic.
Thank you, will look now! In the meantime I was able to change the temperature settings and have the Pro Logic control the temp. When the ProLogic is power cycled though I do have to set 104F in service mode, exit service mode, and then set the desired temp.
 
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread