Problems with new Dolphin S300i

Txjole

Bronze Supporter
Aug 22, 2018
222
Wylie/TX
Has anyone had problem with connecting to S300i via bluetooth? I can set my phone on the power supply and it can not connect. Called Maytronics and was told delete app and re-install. Worked once and back to not connecting. My hope is it's an app update issue and i'm not the only one.
 

JoyfulNoise

TFP Expert
Platinum Supporter
May 23, 2015
14,876
Tucson, AZ
For some reason Dolphin chose not to use Bluetooth pairing with their power supply so there’s an issue with how it interacts with Bluetooth when mobile devices power down BT when it’s not in use. They should have done a better job on that but clearly their app development is not a top priority.
 

JoyfulNoise

TFP Expert
Platinum Supporter
May 23, 2015
14,876
Tucson, AZ
Even when it works it's a frustrating "feature."
I’m ok with it when it works. I do like having access to the advanced cleaning options. But they’re clearly behind the curve when it comes to UI/UX development. They’re obviously employing some very cheap tactics to keep the fixed cost of the system low so that they make a healthy profit but they’re making some strategic blunders in areas that could give them a huge advantage. They also have terrible customer focus and really only care about their distribution channel, ie, pool supply wholesalers.

Right now Dolphin “owns” the robotic cleaner space and has all the market-share they want. But all it takes is for a small upstart to come in with a modern product design, great UX features and a better customer focused relationship and they’ll find themselves left out in the cold.

Their product philosophy and customer attentiveness leaves A LOT to be desired....
 

JoyfulNoise

TFP Expert
Platinum Supporter
May 23, 2015
14,876
Tucson, AZ
Think this could be fixed within the app or is it a hardware issue?
I'm not 100% sure. When I went to the pool store where I purchased my unit from, the tech knew exactly what I was talking about and he had me delete and reinstall the MyDolphin App. His Service App connected to the robot right away so it was not a problem with the hardware, per se. While we were chatting he said that this is a common problem and Dolphin is aware of it but didn't really have a fix for it beyond powering down/powering back up. He too thought it was nuisance and he advises people not to get too hooked on the App...and yes, he was fully aware that people pay money for the extra features and want the app. He was as frustrated as I was about but said there was nothing he could do from his position.

Just doing a cursory check of my phone, I noticed that the Dolphin unit does show up in the Bluetooth device list when the App connects to the power supply but, unlike other Bluetooth devices, there is no pairing protocol initiated. So my guess is that the Dolphin app developers did not use pairing to cut down on constant power draw. But one of the problems with using unpaired devices is that the master device (iPhone or tablet) has to scan continuously to look for BT beacons that may be requesting access or allowing access. My understanding on iPhones (and many other mobile devices) is that beacon scanning is limited to only happening every 3 to 4 mins to avoid excessive power draws. So, the App could launch but see no connected power supply because the phone's internal BT scan hasn't happened yet. Since the timeout for the App is shorter than the phone's beacon scan rate, it looks like there's no devices in range. I don't know of anyone that's going to stand by the power supply for upwards of 3-4 mins for the phone and power supply to talk to one another. If they used pairing, then the power supply would be in a trusted list of devices and, I'm guessing here, phones and tablets likely poll trusted device lists more frequently than randomly scanning for a beacon OR the app could initiate the connection if the phone knows that the device is trusted.

A lot of those are just guesses on my part...only Dolphin can remedy the situation and a look at their App's reviews on the App Store shows that they're not taking the issue too seriously....
 

Arizonarob

Gold Supporter
Silver Supporter
TFP Guide
Mar 25, 2018
1,812
Chandler Arizona
My understanding on iPhones (and many other mobile devices) is that beacon scanning is limited to only happening every 3 to 4 mins to avoid excessive power draws. So, the App could launch but see no connected power supply because the phone's internal BT scan hasn't happened yet. Since the timeout for the App is shorter than the phone's beacon scan rate, it looks like there's no devices in range. I don't know of anyone that's going to stand by the power supply for upwards of 3-4 mins for the phone and power supply to talk to one another. If they used pairing, then the power supply would be in a trusted list of devices and, I'm guessing here, phones and tablets likely poll trusted device lists more frequently than randomly scanning for a beacon OR the app could initiate the connection if the phone knows that the device is trusted.
Why couldn’t you simply open the app, power on the bot, then open the BT setting and drag down to do an immediate scan? Or, on the iPhone, it shows a list of devices that it can connect too, (as in the ones you’ve paired with before) and “force” it to connect by hitting the “i” in the circle?:unsure:
 

JoyfulNoise

TFP Expert
Platinum Supporter
May 23, 2015
14,876
Tucson, AZ
Why couldn’t you simply open the app, power on the bot, then open the BT setting and drag down to do an immediate scan? Or, on the iPhone, it shows a list of devices that it can connect too, (as in the ones you’ve paired with before) and “force” it to connect by hitting the “i” in the circle?:unsure:
I certainly don’t claim to have tried all the various permutations but the App is supposed to activate the Bluetooth on the power supply as soon as you open it up. The fact that it fails to find it is a symptom of some kind of timing mismatch. I use lots of other BT devices (headphones, Apple Pencil, external keyboards, etc) and they never have these comm issues.

Dolphin needs to step up their wireless game or just not bother, plain and simple...
 

JoyfulNoise

TFP Expert
Platinum Supporter
May 23, 2015
14,876
Tucson, AZ
Weird. I’ve never seen two copies show up.

Delete the App. Hard shutdown the phone. Restart. Install the App. Power cycle Bluetooth before opening the App. Open the App.
 
Thread starter Other Threads of Interest Forum Replies Date
J Pool Cleaners 0
F Everything Else 17
P Everything Else 1

Other Threads of Interest