Problem starting Jandy epump

DutchJohn

New member
Apr 15, 2019
1
Poway, Ca
I have a strange problem that hopefully someone can address. I have a Jandy epump VSSHP220AUT variable speed pump that suddenly decided to not start. I stripped the pump down to the motor, checked that the shaft had not seized, and noticed that the drive controller (circuit board, etc..) on top of the motor was filled with water. Since I have had this pump for several years and it's way past warranty, I opened up the drive unit (controller), drained the water and let it dry for a day or so. I then connected the motor to my Aqualink RS (motor only and not connected to pump) and it struggles to start. For a brief few seconds, it turns over at a real slow speed and then dies. I tried this several times, waiting about 3 or 4 minutes between starts and finally - it struggled and then kicked it and started. I thought all was well and let it run for a few minutes, then shut it down and tried to restart to with no luck. It seems to struggle at first and then either kicks in and runs or stops after the initial few turns. I can only compare it to trying to start a lawnmower with the cord when after 4 or 5 attempts the motor kicks in. Could the water have damaged some electronics that now make this motor VERY persnickety?
 
Thread starter Other Threads of Interest Forum Replies Date
F Everything Else 17
N Pumps, Filters, and Plumbing 5
P Everything Else 0

Other Threads of Interest