Prime problem with 2 skimmer baskets

hkljyan

New member
Jul 31, 2019
3
Long Island, NY
my pool has 2 skimmers and when i try to fill the pump basket area with water it keeps getting sucked back into the pool pipe side. I do not understand why the pump basket does not stay full. Due to this i cannot prime my pump. Also when I do turn my pump on and water flows in through the pool side pipe, water shoots out the air relief valve for 5 seconds and then no more water comes out.
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
13,950
Bedford, TX
H,

The reason water runs out of your pump and back into the pool is the same reason you don't float off into outer-space... its called gravity.. :)

When the pool equipment is above the water level in the pool, gravity will cause any water in the pump basket to drain back into the pool. Quite normal.

All you should need to prime your pump is a little water in the bottom of the pump area. The pump creates a vacuum and sucks the water from the skimmers. It if is not priming there has to be another reason other than gravity..

The main reasons that a pump will not prime is..

The pump lid is not on correctly or the O-Ring is damaged or not lubed with pool lube.
Water too low at skimmer.. Should be at the middle of the skimmer mouth
Skimmer Weir is stuck up. Should float up and down with the water.
Valves in the wrong position...

Show us some pics of your set up and maybe we can spot something..

Thanks,

Jim R.
 

hkljyan

New member
Jul 31, 2019
3
Long Island, NY
thank you Jim. I was thinking about the whole gravity thing but other than i have one valve in the system its a ball valve the blocks off flow to a drain pipe. guess theres some leak in one of the PVC pipes
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
13,950
Bedford, TX
Maybe, but unlikely..

I assume it was working fine and then you did something and now it no longer works... ???

If so, what were you doing? Did you vacuum up a bunch of leaves?

What kind of filter do you have?

Jim R.
 

hkljyan

New member
Jul 31, 2019
3
Long Island, NY
i have a DE filter and plus my pump i have a separate pump for an robot automatic cleaner. that pump is connected with the pool pump. tomorrow i will send pictures of the setup

Edit: I realized when I turned on my robot pump the 2 jets would lose all pressure and everything would go for the robot pump. I thought priming it would help