Pool Pump Suction/Return Slows Down After 2 hours.

Artaxias

New member
Jun 6, 2017
2
Los Angeles, CA
Hi, I have a Pentair SuperFlo VS pump and a Pentair DE filter. Both are 3 years old.

Recently, it seems after running for 1-2 hours the suction on the skimmer slows down considerably and the two water return holes (sorry, don't know real term) are returning very little water. The RPM is set at 3000 and the pump seems to be running normally. I checked the gasket on the pump basket and it seems okay? I lubed it using Lubegard that I got on Amazon. I cleaned the filter twice in the last month but still having same issue. Any thoughts or ideas?
 

Attachments

Texas Splash

Mod Squad
TFP Expert
LifeTime Supporter
Welcome to the forum! :wave: One possiblity is algae. Even if it's not green, algae can be in various stages that make it almost impossible to see, or the water may be hazy/cloudy. These organisms will overload a filter quickly, especially a DE filter designed to filter extremely well. Best place to start right now would be:
- How are you chlorinating your water?
- Can you provide a set of home-test results from a TF-100 (link below) or Taylor K-2006C test kit?
- When was the last time you backwashed your filter?

Accurate test results should tell us a lot about your water and filter situation. Nice to have you with us on the forum.
 

Artaxias

New member
Jun 6, 2017
2
Los Angeles, CA
Welcome to the forum! :wave: One possiblity is algae. Even if it's not green, algae can be in various stages that make it almost impossible to see, or the water may be hazy/cloudy. These organisms will overload a filter quickly, especially a DE filter designed to filter extremely well. Best place to start right now would be:
- How are you chlorinating your water?
- Can you provide a set of home-test results from a TF-100 (link below) or Taylor K-2006C test kit?
- When was the last time you backwashed your filter?

Accurate test results should tell us a lot about your water and filter situation. Nice to have you with us on the forum.
I have loads of algae! I will try to backwash and get you results.
 
  • Like
Reactions: Texas Splash