Pool Pump and Filter not filling with water

DosBeerigos

New member
Aug 9, 2018
3
Fort Lauderdale
[FONT=&quot]Hi! Hopefully someone can help. Havent had any issues with the pool since moving into the house a year ago. I took the filter out for a cleaning the other day as pressure was a bit weak and when I got done with the hose down I reinstalled everything and opened the breather valve to refill the collection basket with water in the pump, and wait for the filter housing to fill up with water too. [/FONT]

[FONT=&quot]The basket in the pool pump never filled 100% (filled about 50%). The filter housing (cartridge type) never did either, and instead of pushing air out it was making breathing like motions.[/FONT]

[FONT=&quot]I checked all my valves, connections, and o-rings to make sure everything was tight. It was.[/FONT]

[FONT=&quot]Re-primed the pump and filled it with water, once I turn the pump on the water gets sucked in fast and sits at 50% filled in the basket area within the pump. When I turn the pump off I get a backwash in the piping and the collection area in the pump is filled 100% at which the pump holds the water in. [/FONT]

[FONT=&quot]When the pump is running both the suction and the pressure is operating at about 50% as well.

The impellers have been checked and they are clean.[/FONT]


[FONT=&quot]This is an in-ground pool, 2hp pump.

[/FONT]
I can post pictures or videos if that may help.

[FONT=&quot]Hopefully this is a simple fix.....Your help is appreciated![/FONT]
 

Arizonarob

Gold Supporter
Silver Supporter
TFP Guide
Mar 25, 2018
4,300
Chandler Arizona
Make sure you lube up the o-rings on the filter housing and the pump basket real good with pool lube. Also, fill the bottom half of the filter housing with water before closing it up. Recheck everything to make sure it is all assembled correctly, and check the drain plug that it is tight.

If you could fill in your signature line with all your pool info, it will help others help you. And post up a pic or 2 of your equipment pad. :cheers:
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
21,218
Bedford, TX
db,

Welcome to TFP... A great place to find the answers to all of your "Why is my pool pump not working?" questions, no matter how much "Beer" you can guzzle... :shark:

The number one reason for a pump not to prime, or fill the basket, is the pump lid seal.. Either the lid is not on correctly, the O-Ring is broken or not lubed...

The number two reason is that the water is too low at the skimmer, causing a swirling vortex and the pump sucking air.

Since everything was working fine, before you cleaned your filter, it makes sense that something done during the cleaning sequence is what caused the problem.

Thanks,

Jim R.
 

DosBeerigos

New member
Aug 9, 2018
3
Fort Lauderdale
Thank you both for the fast reply!

Just double checked the o-rings and water level. Everything is seated properly and lubed up. The water level is a bit high due to some rain this week.

When I fired the pump up this last time though some leafs came through the suction side into the basket. I have been cleaning the pool since before this problem occurred. Could a clogged line cause the issues I am having? If so how hard is it to snake a line and is it something I could do on my own?

IMG_20180809_135312.jpg
As you can see the water level sits about half way.....and when running it stays just about there (water is coming into the system though).
IMG_20180809_135635.jpg

Here is a photo of the system setup (again 2hp, 2 speed engine)

IMG_20180809_135318.jpg
 

Rocket J Squirrel

Silver Supporter
Bronze Supporter
Jun 7, 2018
1,076
Alamo, CA
Pool Size
36000
Surface
Plaster
Chlorine
Liquid Chlorine
In the last photo, it looks like the strainer basket lid is not completely tight. The tabs on the lid should both be perpendicular to the flow. I have to tap mine gently with a rubber mallet to get it completely tight.
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
21,218
Bedford, TX
Dos,

I would use a Drain King attached to a garden hose and force water backward from the pump and into the skimmer.. a lot of leaves in your suction line can cause the problem you are having. Take the skimmer basket out first and of course the pump would be open and off...

Here is a link to a drain king.. Drain King Water-Pressure Drain Opener - Walmart.com

They come in all sizes so you need to get one the right size of your plumbing 1.5 or 2"...

You might need to run the water back and forth a few times to get it to clear.

Thanks,

Jim R.
 

DosBeerigos

New member
Aug 9, 2018
3
Fort Lauderdale
Just wanted to take a quick minute and thank everyone....esp Jimrahbe. The Drain King worked! (some pretty gnarly leaves came out of that skimmer line!)

I think I just found a killer new forum!

Thanks again!
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
21,218
Bedford, TX
Dos,

Thanks for the positive feedback, as it may help others with the same issue...

Thanks,

Jim R.
 
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.