Pool opening screwed up

gorocket1981

Well-known member
Jun 8, 2018
162
Montreal, Canada
Hi all,

I screwed up with the pool opening this year. After winter, pool was clear but I was working on many other projects and didn't take care of it.
Time passed and algae formed over the bottom of the pool. I filled it up. I brushed the algae so now I don't see the bottom at all as the water is green and cloudy.

pH is 7.6. CYA probably 0.

I started to put chlorine and I do SLAM. At this point, except doing SLAM is there anything else I should do?
Should I add CYA with the sock? Can I do this while doing SLAM?

I never had this situation before but is is making me crazy. Since we learn by errors, I'll remember this for sure.

Thanks for your indications.
 

YippeeSkippy

Mod Squad
LifeTime Supporter
Jan 17, 2012
16,983
Evans, Georgia
Run a full set of tests to double check that CYA level, as well as checking on everything else. Then if you need to add CYA do it and proceed with the SLAM process.
Almost everything else can wait if your pH is really 7.6.

Maddie :flower:
 

gorocket1981

Well-known member
Jun 8, 2018
162
Montreal, Canada
Yeah!!! I did clear the mess and passed the OCLT.

Quick question. If I added baking soda how long should I wait before I can add Calcium in the pool?

Thanks for the info.
 

YippeeSkippy

Mod Squad
LifeTime Supporter
Jan 17, 2012
16,983
Evans, Georgia
I've always done calcium on a day that nothing else needed adding. Your water may get cloudy for a day, don't worry. Don't overshoot the calcium, only add what your heater needs as the vinyl needs none itself.

Maddie :flower:
 
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.