Pool Motor Leaking Help

Jun 22, 2015
24
Hudson, NH
#1
Hello, My pool motor seems to be leaking all of a sudden. It sprays water where the motor meets the basket and also at the other end of the motor where the Low/Off/High switch is. Do you think this problem is because of the pool motor shaft? Should I go ahead and just replace it to see if it helps?
 

Bama Rambler

Mod Squad
TFP Expert
LifeTime Supporter
Jun 22, 2009
22,897
SouthWest Alabama
#2
That's in all likelihood it's the shaft seal. The water migrating through the motor is not good. I'd get that fixed quickly.

You should be able to find a seal and gasket set for that pump. It's basically a Pentair Dynamo pump and takes a #200 seal set. There are a lot of permutations of that seal, PS200, AS200, S200,... you get the picture. As long as it's got the 200 in it you should be good.
 

Bama Rambler

Mod Squad
TFP Expert
LifeTime Supporter
Jun 22, 2009
22,897
SouthWest Alabama
#4
It's probably a good idea to get a casing o-ring just in case you damage it when taking the pump apart.
Other than that, the seal is all else you should need.
 
Jun 22, 2015
24
Hudson, NH
#7
There is not screw on my impeller. The shaft looks really rusted so I think it might just be stuck on. I'm considering just breaking the impeller off and replacing it. This pump is at least 10 years old. Do you think its worth replacing or fixing?
 
Jun 22, 2015
24
Hudson, NH
#9
In the end I decided that the pump was not worth repairing. The shaft was so rusted that I would rather buy a new pump and not have to worry about something like this happening again. Found a cheap replacement new for $130 and it works great. Thanks for your help everyone!