Pool Math App not keeping updated data

Hello,
I’ve been enjoying this website and purchased the pool math app. It worked great for me last year, but this year it keeps the default values. If I enter my measured values the page changes and I can see what to add. But as soon as I leave that particular section, all my values revert back to default.
I have tried logging out and logging back in. Deleting the app and reinstalling the app and logging in. I am on iPhone, one short of the new 13.5 iOS.
Any ideas on how to get it to retain my test results?
 

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
29,926
Laughlin, NV
You do not have to post the link. I just go to your member name and the link to your Poolmath Data is there.

I see the test data is not saving. Are you touching the check mark in the upper right to save the data?
 
So maybe I’m not logged in? I logged out and log back in and no change. However I noticed when I clicked “restore purchases “it popped up asking if “my phone has been in the water because I can’t reach the clouds quote. My expiration is August of this year. So maybe I have some sort of connectivity issue. I’m online, and posting with my phone right now.