Pool Heater not Heating

RhoOmegaBeta

New member
Feb 8, 2020
4
Florida
Hi everyone. About a month ago my pool heater stopped heating the pool. It still runs but even leaving it on for hours won't heat the spa. Are there any troubleshooting steps you recommend to narrow down the issue?
 

Attachments

setsailsoon

Gold Supporter
LifeTime Supporter
TFP Guide
Oct 25, 2015
3,465
Stuart/FL
Rho,

Welcome to TFP! You've come to the perfect place. We have experts in everything pool and we sell nothing. Just like to give away great advice.

It might help our experts if you could add a little information. Here are a few items to start with:
  • Are any codes displayed on the panel. If so,, what codes?
  • When you say it runs what do you mean? Can you hear the compressor? W
  • hat's the ambient temp where you live in Florida?
  • What's the pressure on your filter?
  • Is the return water to the pool warm or hot and is the flow normal?
Chris
 

RhoOmegaBeta

New member
Feb 8, 2020
4
Florida
I don't see any error codes. The panel just displays the temperature settings. It sounds like the compressor is still kicking on. Ambient temp was around 70 today but warmer the other times I tried to use it recently. I just replaced my pool filter, pressure is around 17 for pool 22 for spa. Return water is cold but flow is normal.
 

RhoOmegaBeta

New member
Feb 8, 2020
4
Florida
Thanks for the recommendation, sorry it took awhile to get back to you. The AC company I bought my new units from a couple years back took a look and a capacitor was bad. They fixed it up and it's good to go again. Thanks!

Edit: typed compressor instead of capacitor
 
Last edited: