Polaris P955 will not turn on

Curacaoblue

New member
May 19, 2020
1
NC
I have a Polaris P955 that I bought in January 2017. It’s been used a total of 6 months since we close the pool off season. No issues until last month when it started shutting off when I clicked “start”. I went to Leslies and after I told them I wouldn’t be buying a new one they finally looked at it and told me it was the power cord. I fixed the frayed cord at the connection to the power box and it started working again... for about 10 minutes. Then a few minutes, seconds, now it won’t start at all. I have googled nonstop without luck. I’m really hoping someone can help.
 

pilotbob3

Active member
May 21, 2010
31
Are you sure you repaired your power cord correctly? Does the control box come on at all? Is there power at your outlet?

Sorry to be ask basic questions, but the only failures I have seen on a control box not turning on and displaying anything turned out to be a blown fuse inside the unit.
 

USMChris

Member
Jul 12, 2020
5
New York
I have a similar issue with a 955 that is a year old and only been in use for 4 months. My turns on but it won't get past the error code ten on the control panel.
 

pilotbob3

Active member
May 21, 2010
31
Error code 10 means that the controller can't talk to the motor block. It is usually a sign that the motor block has failed due to a leak. Not always, but usually. If your 955 is just a year old, give the Polaris tech support a call. They are usually pretty good about sending a replacement. It is pretty easy to replace the motor block.