Polaris 380 No Suction

lessma

New member
Jun 30, 2010
3
I have a Polaris 380 with booster pump, paired with Pentair Superflo VS pump. Running the Superflo at 3450 with the the Polaris booster pump.
  • Polaris is running 30 RPM with blue restrictor washer,
  • water management system has been replaced,
  • three jets have been checked for debris and cleared.
  • all lines have been checked for leaks
  • knuckles between hose sections seem to be functioning without leaks
  • STILL nothing gets sucked into the bag! Seems to be running flat to the pool surface. Any suggestions would be appreciated!
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
11,814
Northern NJ
-Does it move well on the pool floor?
-Does it climb walls?
-Is there a strong stream out of the tail?
-Do the 3 jets inside the bag make a nice fountain?
-Is the bag sealed with no holes?
-Do you see the bag inflate up when running?
 

jtpipkin

Bronze Supporter
Oct 2, 2016
184
albany, ga
Can't tell if you've done this from your description or not, but check the hose to make sure it's got good connections inside the red circled area. Mine comes undone from time to time and I never remember to check it until I pull it out and pull it apart...
Graphic1.jpg
 

sktn77a

Gold Supporter
May 16, 2010
1,454
Chapel Hill, NC
If the 3 jets in the vacuum channel are working, there's no reason it shouldn't be cleaning. How high do the 3 jets shoot water up into the air if you run it at the pool surface?
 

davidgreams

In The Industry
Sep 28, 2019
3
Foster City
It sounds as if the little venturi (Or jet) that drives the pinwheel paddle is clogged. Unscrew the single screw that holds the paddle cover in place. Tape a straightened paper clip to a screw driver and dislodge anything down there. Hook it up and test it again. If this does not work, you may need a new Water Management System.

Btw, most booster pumps are 3/4 HP. I'm sure your pump is not the issue here though...

Hope this helps!