Pentair Warrior SE - length of power cord and Aux power control

jphaus

Member
Mar 28, 2012
17
Oh, that's good to know because I always worry about my kids turning things on that they shouldn't. They can't resist talking to Google. Thanks!
 

jphaus

Member
Mar 28, 2012
17
I didn't measure it because I had to go with my own "Plan C" (weatherproof enclosure) but I think it's probably 6-8 feet long.
 

markayash

Gold Supporter
Mar 21, 2016
1,536
Marrietta Ga
Been using it for a few days and it's nice, I have a schedule set to run from 5am until 7 am
Last time I wanted to run it and pushed the power button and disabled automation, now I know

The cool thing is I bought a refurbished Echo off amazon and have it on the back deck but well covered.. I can say " Alexa turn on the Dolphin for 1 hour" and it will :)
 

geko29

Gold Supporter
Apr 27, 2018
96
Schaumburg, IL
I noticed that no one addressed the cord length question. The cord that came with my Active 30 (same as the S300) is quite short, certainly 6 feet or less. However, it is a standard C13 power cord like you'd find on a desktop computer or many other types of electronics. So you can very easily and cheaply replace it with a longer one like this ten-footer for $3.59, which is also available in a 15' for $4.69, 20' for $5.60 or 25' for $6.25.
 

jphaus

Member
Mar 28, 2012
17
I noticed that no one addressed the cord length question. The cord that came with my Active 30 (same as the S300) is quite short, certainly 6 feet or less. However, it is a standard C13 power cord like you'd find on a desktop computer or many other types of electronics. So you can very easily and cheaply replace it with a longer one like this ten-footer for $3.59, which is also available in a 15' for $4.69, 20' for $5.60 or 25' for $6.25.
Great point @geko29, as in order to fit into the enclosure I mentioned above, I had to get a right angle plug like this. It was needed because the end of the blue cable takes up a lot of length inside the enclosure and you don't want to bend it too much.

I've attached a couple of pics. The power supply is upside down because the pool is on the right side of the house from the enclosure and I needed all the length of blue cord I could get to reach the end of the pool.
 

Attachments

markayash

Gold Supporter
Mar 21, 2016
1,536
Marrietta Ga
Great point @geko29, as in order to fit into the enclosure I mentioned above, I had to get a right angle plug like this. It was needed because the end of the blue cable takes up a lot of length inside the enclosure and you don't want to bend it too much.

I've attached a couple of pics. The power supply is upside down because the pool is on the right side of the house from the enclosure and I needed all the length of blue cord I could get to reach the end of the pool.
Is that a smart outlet between the cords? If so you can use automation mode ad control it from your phone :)
 

poolH2O

Member
May 8, 2020
9
New Jersey
The automation mode works for me on the Warrior SE. You have to hold in the weekly timer button starting with the power off.

When automation mode is then turned on, the power supply turns on and off (and starts up the robot automatically) when the power is applied or removed. I'm going to try hooking it up to a TP-Link Kasa Wi-Fi outlet next. The blue cord isn't long enough to go with my original plan so this will be my backup.

Thanks for the help everyone!
Hey there,
I also got Warrior SE also, I tried activating automation mode as you suggested which worked for me only for the first round of cleaning once power is applied. It won't start the cleaning cycle next time when power is turned on, is this the case for you as well? How do you keep in automation mode all the time? I also wanted to connect cleaner to smart outlet and setup a power on/off schedule for cleaning instead of relying on a built-in weekly timer schedule.
 

poolH2O

Member
May 8, 2020
9
New Jersey
Jim, it does work! I did mine and nothing happened so I assumed it did nothing..But after reading jphaus' comment I went out turned it off, then unplugged and reconnected and the cleaner started ;)

That's perfect, all I really wanted to do, start it from my phone or schedule it to run when I want it to..I am going to have it come on early AM before the guard dogs wakes up but late enough for a clean pool
Hello,
I also tried automation mode as spelled out by "jphaus" for Warrior SE. Are you able to keep cleaner in automation mode after the first cleaning cycle ends or the automation mode works only for one time when power is supplied to the cleaner and you have to repeat steps to set automation mode again? For me, it's only doing one cleaning cycle and nothing happens after I turn on power the next day.
 

markayash

Gold Supporter
Mar 21, 2016
1,536
Marrietta Ga
Mine has been working for a few weeks. Did you push the power button on the physical power supply by chance? I think if you do that it disables it

I put a hair net over mine to remind me not to push it
 

poolH2O

Member
May 8, 2020
9
New Jersey
Mine has been working for a few weeks. Did you push the power button on the physical power supply by chance? I think if you do that it disables it

I put a hair net over mine to remind me not to push it
Thanks for the quick reply. If it's working for you then I must be doing something wrong, I'll troubleshoot more. So what's your smart plug schedule like? Is your smart plug scheduled to turn off before default 2h cycle finishes or you wait longer than 2 h so cleaner default cycle is complete and then kill the power to the cleaner?
 

markayash

Gold Supporter
Mar 21, 2016
1,536
Marrietta Ga
I did wonder if there is a limit for it running over 2 hours also..I have mine set to run from 5:30 until 7:20 so it ends before the 2 hour. Now that you mentioned that I have turned it on and forgot and noticed a few hours later it wasn't moving but seemed OK the next day..
Not sure and I asked Pentair and got a generic That won't work :) I replied back and explain it does work and wanted more info and went to file 13 I guess
 

poolH2O

Member
May 8, 2020
9
New Jersey
I did wonder if there is a limit for it running over 2 hours also..I have mine set to run from 5:30 until 7:20 so it ends before the 2 hour. Now that you mentioned that I have turned it on and forgot and noticed a few hours later it wasn't moving but seemed OK the next day..
Not sure and I asked Pentair and got a generic That won't work :) I replied back and explain it does work and wanted more info and went to file 13 I guess
This is very helpful, I think this is it. My on/off schedule for the smart outlet is set up for longer than 2h, I'll try again like yours with under 2h schedule and find out if it works. I highly doubt Pentair would like to acknowledge that ~$20 smart outlet solution is as functional as their expensive higher-end models with built-in wifi.
 
  • Like
Reactions: markayash

jphaus

Member
Mar 28, 2012
17
Automation mode continues to work for me and I've not touched the power supply once since I first got it all installed. I don't schedule my smart outlet to turn off until the overnight hours when the robot is for sure not cleaning. I never turn it off while the robot is cleaning, in case that makes a difference. I just let the robot run a complete cycle and turn itself off.
 

markayash

Gold Supporter
Mar 21, 2016
1,536
Marrietta Ga
Automation mode continues to work for me and I've not touched the power supply once since I first got it all installed. I don't schedule my smart outlet to turn off until the overnight hours when the robot is for sure not cleaning. I never turn it off while the robot is cleaning, in case that makes a difference. I just let the robot run a complete cycle and turn itself off.
How or when do you start the cleaning cycle?
 

jphaus

Member
Mar 28, 2012
17
By turning on the smart outlet manually from the app or by voice. Then I just leave it on all day until it automatically shuts itself off at a set time overnight.
 
  • Like
Reactions: markayash

poolH2O

Member
May 8, 2020
9
New Jersey
So in my case, I can confirm that automation mode stays in the memory only if I schedule to kill the power anytime before the end of the default 2h cycle. It can be after few seconds or 1:55 mins, as long as power is killed during the cleaning cycle. Within 5 seconds of turning the power ON cleaner starts it's cleaning cycle again. If I let cleaner completely finish its default 2h Cycle then automation mode doesn't work for me again. "jphaus" - Can you confirm that this is true in your case as well (?)
 
  • Like
Reactions: markayash