Pentair Superflo VS Dead

DDGMAN

Bronze Supporter
Oct 12, 2016
26
Wadsworth/OH
I installed a Superflow VS last spring I got on Doheny's on sale. Last week the pump was off and not showing power LED despite getting 120V to input L1 and L2. I think the electronic controller fried. The only Pentair Authorized repair shop in the area I could get to look at it said they cannot fix it after holding onto it for a week as my pool turns green. The only other somewhat close shop said they wouldn't even look at it since I didn't buy from them. Warranty is only for 1 year on that model, so I am out of luck. I decided to take a chance buy a new drive assembly part 353127 for $200 I found one at half price on ebay to see if that gets it working again (throwing good money after bad I know). Has anyone else had a similar issue with this pump? A search didn't turn up much so I hope I am an isolated incident.
 

IL_WS

Well-known member
Sep 18, 2012
125
IL, NW of Chicago
I have no experience with the pump. However, you may want to check the extended warranty terms of the credit or debit bard you used to purchase it a year ago. Many will double the warranty.
 

Culleebo

Bronze Supporter
Jul 30, 2018
20
Raleigh, NC
I hope that model isn't a 342001 SuperFlo VS... like the one I bought and is coming on Friday...

I've heard these kicking the bucket early, and now I'm only more worried.
 

DDGMAN

Bronze Supporter
Oct 12, 2016
26
Wadsworth/OH
Unfortunately it was. If you keep it make sure you register it within the specified time frame. Even then if you bought it online it seems local dealers won't do work on it. I was able to get it fixed by replacing the whole electronics motor control enclosure I bought used on eBay. I plan to take the old controller apart and see if anything is fried on the circuit boards or other insides. My original display panel is probably fine.

- - - Updated - - -

Also if you are running it on 220V maybe you will have better luck. I was running it on 120V which maybe it doesn't like too much.