Pentair Super Flo 1.5hp making “whining” noise

oz0311

New member
May 14, 2021
2
Boca Raton
Pool Size
16000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Hayward Aqua Rite (T-9)
Hi all,
I’m new to the forum and would love to get some advice/input from some of you experts out there. I have a Pentair Super Flo 1.5hp pump that’s only 3 years old which I bought new and had installed from my local pool store. Yesterday I noticed it started making what I can describe as a high pitch “whining” sound coming from the motor area. It obviously didn’t sound right so I turned off the pump to prevent any damage. I started searching online for some answers and I came across two solutions; replacing some bearings or replacing the motor all together. Now, I’m somewhat handy but from what I’ve read it seems the bearing replacement might be a little outside my comfort/skill level. The motor replacement seems more along my speed. Can any of you fine folks out there tell me if the solutions I found seem appropriate? Also, would it be more cost effective to just replace the motor or send the current motor to be serviced by my local pool store. I also don’t understand how it’s only been a few years and I already have to replace parts on this pump. I’ve never ran the pump dry and always prime it properly when cleaning out my filter. Is this a common issue with variable speed pumps or is it possible I just have a lemon? My previous pump was a Hayward single speed pump which lasted over 10 years without even replacing the motor. When that pump finally died on me that’s when I decided to try out the more energy efficient variable speed pump. Just my opinion here, but it seems like I probably made the wrong choice. Anyhow, I would greatly appreciate any input with my issue. Thank you in advance.
-Ozzie
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
29,119
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
Welcome to TFP.

Post pics of your pump and the motor data plate.

You say in the beginning of your post that your pump is a "Pentair Super Flo 1.5hp pump" which is a single speed pump. But then towards the end of your post you say you replaced your SS pump with a VS pump.

You can call around to your local motor repair shops but I think you may find it just as cost effective to replace the motor. You need to price out the two alternatives.
 

oz0311

New member
May 14, 2021
2
Boca Raton
Pool Size
16000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Hayward Aqua Rite (T-9)
Welcome to TFP.

Post pics of your pump and the motor data plate.

You say in the beginning of your post that your pump is a "Pentair Super Flo 1.5hp pump" which is a single speed pump. But then towards the end of your post you say you replaced your SS pump with a VS pump.

You can call around to your local motor repair shops but I think you may find it just as cost effective to replace the motor. You need to price out the two alternatives.
Hi ajw22,

Sorry for the confusion. My Pentair Super Flo pump is in fact VS pump. I’ve attached some pictures of my pump along with info that’s near the motor housing.

So just an update...I decided to clean the filter and turn on the pump earlier today and that high pitch “whining” noise and rattle is gone. I have to idea what could’ve caused it but I’m glad it’s gone, atleast for now. The idea of having to spend some money to fix the pump was a little stressful considering we are still recovering from a recent large purchase. I will keep an eye on the pump and see if the noise comes back.
 

Attachments

  • F9B15316-8557-47F4-9C52-8FBD332DB5CE.jpeg
    F9B15316-8557-47F4-9C52-8FBD332DB5CE.jpeg
    749.2 KB · Views: 3
  • 13DD92B0-7EFF-4FC5-A050-C7B2C512E76D.jpeg
    13DD92B0-7EFF-4FC5-A050-C7B2C512E76D.jpeg
    330.7 KB · Views: 3
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread