Pentair ScreenLogic: Connecting to Pool Controller Please Wait

peacefulkancer

Gold Supporter
LifeTime Supporter
Aug 5, 2013
203
Chandler, AZ
Pool Size
12000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
Have the Pentair 522104 Screenlogic2 Interface & Wireless Connection Kit that reads "Connecting to Pool Controller Please Wait" when trying to connect on PC. On phone it connects, but the statuses are all incorrect.

Protocol Adapter has Red light on it
Indoor Wireless Transciever has PWR rapidly flashing (~3 flash/sec), TX and RX are not flashing
Outdoor Wireless Transciever has PWR slowly flashing (~1 flash/sec), TX never flashes (dont even see a RX LED)

Tried power cycling the Protocol Adapter and the Indoor Transceiver to no effect.

I cannot hard wire the units together to test. Is there any way to definitely test?
 

peacefulkancer

Gold Supporter
LifeTime Supporter
Aug 5, 2013
203
Chandler, AZ
Pool Size
12000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
Bought around March 2018. And yes it has been working since.

It actually started working after I posted, but it seems sketchy.
 

guinness

Well-known member
May 3, 2019
553
California
Take a look at the following thread, wireless interference was causing a problem for that person.

 
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread