Pentair OptiFlow Pump noise, squealing. Too cold? Looking for advice on repair/replacement

sdd142

New member
Jul 4, 2018
2
Verona PA
Pool Size
14500
Surface
Vinyl
Chlorine
Liquid Chlorine
Hello,

I'm on year 4 of my first above ground pool experience. This is my first time running into pump issues. Wondering if anyone can give advice on the noises I'm encountering, and if I should start to look into a replacement. I opened early this year prepping for a Raypak NG heater install. I'm in the Western PA region. I've never opened this early, and temps have been pretty cold. 30s-40s in the morning, getting up to 50-60s in the afternoon. Pool is open, water is clean and balanced, and the pump PSI (sitting around 14psi) and flow is good. But the pump is making noises I've never heard before:

Yesterday, Bubbling/Sloshing? noise near the Volute assembly:
To troubleshoot this noise. I visually checked for air/water leaks. Did not find any. There is barely any visible air getting into the pump basket. I also dissassembed the pot and volute assemblies, cleaned and lubed all of the threads/O rings and cleaned out the impeller. I did not find any blockage, chips, damage in any of these parts. The only seal I did not touch was the mechanical seal at the end of the motor shaft, I did not remove the seal plate. After all of this cleaning and re-assembly. The noise was still there yesterday, and the pump psi/flow and performance were still fine.

This morning, outside temp in the low 30's. The Bubbling/Sloshing noise continues. But now I also have what sounds like a scary bearing whine. Could this be due to the cold? I ran the motor yesterday and it was purring just fine:

I'm at a loss on where to go from here. Its been recommended by the folks I'm working with on the NG Heater install to get a replacement. I'm disappointed I may have only gotten 3 seasons out of my current pump. But I'm also not that happy with it anyway. It was very noisy. Appreciate any advice on:
- What could be going on with my current pump? Could it be the cold temps shrinking things, allowing air getting in, and also causing the whine? Would anyone continue to troubleshoot/fight the current pump? Or,
- I'm ready to buy a replacement pump if thats best, and I'm looking to get one asap since my pool is open and I'm trying to get the heater install done. It doesn't look like my current model is available right now anywhere online. Any advice on where to find a good replacement pump that will fit my Clean and Clear Cartridge filter CC150 setup? I'm hoping to find something I can just swap right in, and something that is the power I need, but hopefully a bit quieter than my current Pentair 2HP 340078. There are unions for the pump to connect to the cartridge housing. So as long as things line up should be able to screw things right in.

Appreciate any advice on where to go next

Motor purring just fine Disassembled yesterday:

Thanks!

Current Pump/Filter Cartridge Setup:
- Pool: 24' ABP, 14,500 gallons
- Pump: Pentair Optiflo 2hp pump P/N 340078
- Cartdrige: Pentair Clean and Clear Cartridge filter CC150
- 20A dedicated electric line for pump
- 1 1/2" piping
 

Attachments

  • PXL_20210426_133032694 (1).jpg
    PXL_20210426_133032694 (1).jpg
    339.7 KB · Views: 1
  • PXL_20210425_200901015.jpg
    PXL_20210425_200901015.jpg
    672 KB · Views: 2
  • PXL_20210425_130714916.jpg
    PXL_20210425_130714916.jpg
    309.1 KB · Views: 2
  • PXL_20210425_202907484.jpg
    PXL_20210425_202907484.jpg
    336.3 KB · Views: 1
Last edited:

sdd142

New member
Jul 4, 2018
2
Verona PA
Pool Size
14500
Surface
Vinyl
Chlorine
Liquid Chlorine
Update: The pump got a little sun this morning. Now the high pitched whining is gone. I'm back to the loud bubbling/sloshing noise again that was there yesterday. Maybe nothing is wrong at all? Cold temps again perhaps letting some air in? This bubbling/grinding/sloshing noise is pretty loud. Can hear it 20ft away and it just started this year.

Or maybe this is the beginning of things starting to fail.

Thanks!