Pentair Mastertemp E01 Error Code

dedwards63

New member
Nov 22, 2017
2
Mapleton, Utah
I started having a random, erratic problem with my 2yr old Pentair Mastertemp 400 natural gas heater in October. Using either the EasyTouch keypad, or my Pentair ScreenLogic app on my iPhone, I turn the spa on... give it a minute or two, then turn on the heater.


  1. System goes into Spa mode
  2. PENTAIR MASTERTEMP 400 turns on
  3. Goes through the standard boot up procedure (128/R13 appear on the LCD of heater)
  4. Then the display shows "1"
  5. The heater fires up and starts heating for about 3-4 minutes
  6. Then it errors out with E01... and keeps the code on for a long while.

I check the back of the control board in the heater and the LED7 light is on, which is right next to thermistor plug... so, it seems to be a bad thermistor. I replaced the thermistor today and it did the same thing.

For the fun of it, I unplugged the connector to the thermistor from the board and tried firing it up... it did the same thing, even with the thermistor not plugged in.

Thoughts?
 

ps0303

TFP Expert
In The Industry
Jul 6, 2011
4,049
FL
How does all of the wiring look? No rodents have been living in the unit and chewing on anything?

I would do this, power off the unit from the breaker, and then remove and inspect both sides of the control board. Make sure there are no signs of any corrosion on it.
 

dedwards63

New member
Nov 22, 2017
2
Mapleton, Utah
All wires looked good... looks clean inside. I tried shutting everything down, restarting, etc., etc.

Finally, I called a friend who has been collecting some old Mastertemp 400 parts, and he just happened to have an extra control board he let me borrow. I actually just took the whole top of the unit he built with parts and once I plugged everything in, the spa worked just fine.

One sign that I should've given more attention to was the display only showing "1" after it kicked on and started heating. When it is working like it should, it should actually show the temp of the water flowing into the unit from the suction side.

Anyway, now I just have to go and search for a decent deal on a new control board... and, I replaced the thermistor for no real reason ;-)

What is that old saying, "a pool is just a hole in the ground that you throw money into" ... well, and have a lot of fun along the way, too!

Thanks for the input and help!
 
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.