Pentair Mastertemp 400 cycles heat on and off

rstoy56

New member
Jun 19, 2019
1
orange, ca
Hi all, my Pentair Mastertemp 400 cycles heat on and off. I replaced the ignition control module and the thermal regulator, but it still cycles on and off and will not give an error code. The heater will fire up to about 300 degrees, then it shuts the flame off, then the temp goes down to about 200 degrees and the flame comes back on, then the cycle begins again until the desired temperature is finally reached. I would appreciate any guidance you all can give.
 

JamesW

TFP Expert
Mar 2, 2011
15,641
Where are you getting the temperature of 200 and 300 degrees?

Did you check the back of the circuit board for error lights?

The following are the LEDs:

1.....PS (Pressure Switch)
2.....HLS (High Limit Switch)
3.....SFS (Stack Flue Sensor)
4.....AFS (Air Flow Switch)
5.....AGS (Automatic Gas Shutoff).
6.....Service System
7.....Thermistor
8.....Heating
9.....Pool On
10...Spa On
11...Service Heater.


Cycling is usually due to a high limit error. A high limit means that the water in the heater is getting too hot. This is usually due to a bad thermal regulator.

A bad internal bypass can also cause the high limit error. You can see one half of the internal bypass by looking in the the water inlet (it's a spring bypass). You can see the other side of the internal bypass by removing the thermal regulator and looking for a round disc.

Insufficient water flow due to a pump speed being too low can be an issue for variable speed pumps.

An open external bypass can also cause the high limit error.
 
Last edited:

ColoradoKid

Member
Feb 20, 2019
6
Boulder, CO
I've got the same problem with a MasterTemp 250. It runs for 2-3 minutes than triggers the Service Heater light. I've checked the LEDs on the board and nothing is triggered. So what could it be?