Pentair Legend Platinum Tail Getting Stuck

jobondur

Well-known member
Dec 13, 2009
182
Virginia Beach, VA
I have a Pentair Legend Platinum of unknown age (came with the house in 2009) with booster pump and it has started to get its tail stuck in between the wheels and the body of the unit (usually but not always the front right). It either gets up under the unit and then stuck or sometimes it even gets stuck on the top side of the unit. Just quickly looking at it, I don't see anything obvious jumping out at me and I'm worried that if it keeps happening I'm going to strip my gears. Only modification is the tail kept blowing off a while back and I used a stainless steel cable clamp to put it back on.

Any ideas???
 

jobondur

Well-known member
Dec 13, 2009
182
Virginia Beach, VA
I think I may have found the answer to my issue. Turns out you can turn down the pressure of the sweep hose so it doesn't whip around as much via an adjustment screw. I'll try that tonight and see if it fixes the problem.
 

cruzr

Member
Mar 8, 2014
20
St.Louis, Mo.
I would definitely purchase a tail scrubber sponge (black thing) for the end. That and the hard rubber rings will keep your tail sweep from wearing a hole in the hose. You can purchase a 3 pack for $5.00 Also if you haven't purchased a replacement hose since 2009 your due. They tend to lose their flexibility with age.
 
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.