Pentair Kreepy Krauky Platinum pressure side cleaner not working even though pump is

mwalling

Bronze Supporter
Sep 17, 2016
188
Dallas, Texas
#1
I'm trying to trouble shoot my pool cleaner. When I got home today, I found the pump running as scheduled but the cleaner wasn't moving. When I checked it, there was no water flow to it. Any ideas?

Thanks!!


Sent from my iPad using Tapatalk
 

YippeeSkippy

Mod Squad
LifeTime Supporter
Jan 17, 2012
9,230
Evans, Georgia
#2
Is this a pressure or suction side cleaner??

What was your filter pressure? Was it unusually high?

Do you have any valves that accidentally got turned?

Clogs in the line of the cleaner??

Yip :flower:
 
OP
OP
M

mwalling

Bronze Supporter
Sep 17, 2016
188
Dallas, Texas
#3
Is this a pressure or suction side cleaner??
As stated, it's a pressure side

What was your filter pressure? Was it unusually high?
Normal filter pressure

Do you have any valves that accidentally got turned?
I was hoping that was it but they are all in the proper position

Clogs in the line of the cleaner??
I guess that could be the case. That's my question. How do I tell if it's a clogged line, pump problem or something else...








Sent from my iPad using Tapatalk
 

YippeeSkippy

Mod Squad
LifeTime Supporter
Jan 17, 2012
9,230
Evans, Georgia
#4
OP
OP
M

mwalling

Bronze Supporter
Sep 17, 2016
188
Dallas, Texas
#5
Well, Skippy's all purpose tool of choice is always a wire coat hanger.... I don't endorse this at all....but have to admit it has worked a million times or two. And when it doesn't work, his second favorite tool comes in to play: *100 mile an hour tape* aka Duct Tape.

Let me think of this a minute and I'll get back to you....

Yippee :flower:

Kreepy Krauly pool cleaner troubleshooting and repair information

KREEPY KRAULY PARTS DIAGRAM, Kreepy Krauly parts, Replacement parts for kreepy pool cleaners
Thanks! You've given me several things to check tomorrow. Thank you!


Sent from my iPad using Tapatalk
 

Pool Clown

In The Industry
Sep 5, 2008
1,836
Silicon Valley, CA
#6
There should be either an inline finger screen, or one in the wall fitting.

Turn the pumps off. BTW, when the cleaner runs, the filter is running too, rrright???

Just checking...

Go to the waters edge and twist the wall fitting CCW about a 1/4 turn, the fitting should come out in your hand. Look at the opening, and you should be able to see the finger screen. Make sure that it is clear and set the assembly on the deck. Go back to the equipment and turn the filter and cleaner pumps back on. The cleaner pump may make some unusual noise, that's ok. Go back to waters edge and confirm that there is good flow coming from the cleaner wall fitting. If you have good flow, go and turn off the pumps and replace the cleaner hose to the wall fitting. Turn everything back on and see if it is operating normally. If it is moving slowly, then i would either bring to a shop that works on them to clean out the jets, or you can try this yourself if you feel comfortable doing that sort of thing.

Note: if your finger screen is in place and doesn't have any rips in it, the drive jets in the cleaner shouldn't be clogged with anything. Also, this is a summer 2016 build, yes? Your problem may be a warranty issue, and shouldn't have to pay for if you determine that you need someone to come out. If so, call Pentair.
 
OP
OP
M

mwalling

Bronze Supporter
Sep 17, 2016
188
Dallas, Texas
#7
There should be either an inline finger screen, or one in the wall fitting.

Turn the pumps off. BTW, when the cleaner runs, the filter is running too, rrright???

Just checking...

Go to the waters edge and twist the wall fitting CCW about a 1/4 turn, the fitting should come out in your hand. Look at the opening, and you should be able to see the finger screen. Make sure that it is clear and set the assembly on the deck. Go back to the equipment and turn the filter and cleaner pumps back on. The cleaner pump may make some unusual noise, that's ok. Go back to waters edge and confirm that there is good flow coming from the cleaner wall fitting. If you have good flow, go and turn off the pumps and replace the cleaner hose to the wall fitting. Turn everything back on and see if it is operating normally. If it is moving slowly, then i would either bring to a shop that works on them to clean out the jets, or you can try this yourself if you feel comfortable doing that sort of thing.

Note: if your finger screen is in place and doesn't have any rips in it, the drive jets in the cleaner shouldn't be clogged with anything. Also, this is a summer 2016 build, yes? Your problem may be a warranty issue, and shouldn't have to pay for if you determine that you need someone to come out. If so, call Pentair.
Thank you! I'll post an update when I figure it out.


Sent from my iPad using Tapatalk