Pentair Intelliflo LCD screen backlights and buttons work, but nothing on Display

jbailey895

Well-known member
Apr 25, 2016
113
Carlsbad, CA
Hi-jacked someone else's thread yesterday, figured I should start my own instead. I have the 011018 Intelliflow, just out of warranty (of course). Pump works fine, but after a power outage a month or two ago, the timer reset, and I have nothing on my LCD screen. All the buttons work, and the backlight on the screen is illuminated, but there are no words/images on the screen. I can still turn it on, and switch pump speeds, but cannot program or see anything.

I read the other threads dealing with loose contacts on the LCD screen, but when I went to take the screws off, I realized to get to the back of the LCD, I need the specialized hex screws on the wider plate for the pump. The three phillips only take off the outer case, and the PCB etc are below the rubber seal. I don't want to break the rubber seal, so I guess I need a specialized screw head to remove the screws?

Any suggestions appreciated
Thanks,
Joel20160428_123045[1].jpgLCD panel Pentair.jpg
 

ColdAirGuy

Platinum Supporter
LifeTime Supporter
May 25, 2010
85
California
I've had the same thing happen with my pump a few times over the last couple of years. Each time it has self-corrected with a simple cycle of the power. I did see the thread you mentioned as well and anticipate having to open my panel up in the near future for a look.
 
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.