Pentair Intellichor Experience???

ktdave

LifeTime Supporter
May 8, 2007
888
Katy, TX
I've had one (IC-20) for about 6 months that has worked flawlessly. The only odd thing that has happened is that it appears that occasionally when the water temp falls below 50 degrees the "clean cell" light has come on and then went off when it warmed back up. There was no scale on the cell after inspecting.
 

hodapmj

LifeTime Supporter
Oct 2, 2007
54
Arkansas
Have an Intellichlor that runs flawlessly. ktdave stated that his clean cell light comes on when the water temp goes below 50 degrees, this is just an indicator that the cell is not producing chlorine as it is not needed below this temp. Actually it is about 55 degrees that this feature kicks in. Mine is connected to the Easy Touch 8 controller which also has been a pleasure to own.
 

Andiejj

Well-known member
Jul 19, 2007
188
Katy, TX
I have one as well. I like it but had some problems. Mine is less then a year old. Several months after my pool build I noticed I was constantly throwing salt in the pool. I started to keep track of it and it was about every 2-3 weeks. Having never had a pool before I was not sure what was "normal" but I got suspicious and contacted my PB about it and my Intellichlor had to be replaced. Sure hope this was just a bad system and this will not be a regular issue. Mine is hooked up to an intellitouch and love the convience of checking things or changing settings while in my house ;).
 

EskimoPie

LifeTime Supporter
Jul 27, 2007
278
Sahuarita, AZ
I have an IC-20 connected to an easytouch system. I'm happy with mine so far although it did have to be replaced once under warranty. It lost the ability to measure salt levels accurately... reading 0 ppm on day then 8000 ppm on another. They ended up replacing the cell and all is well...
 

LeeD

In The Industry
Feb 4, 2008
45
I have only worked with two brands of SWG's, Pentair and Goldline. I have had a lot of the Pentair units stop reading salt levels correctly not long after installation (1-3 months). If they survive this period, they seem to work excellent. Goldline aquarite cells have been very reliable for me though. Early models (before mid-2006) were very poor and failed frequently, but since then, I have only had one in over 100 fail to date. That is, that wasn't due to abuse or poor maintenance.
 

billyjoeraybob

LifeTime Supporter
Apr 9, 2008
50
SC Midlands
I have only had my Intellichlor IC40 since Saturday but it was a breeze to install and has worked perfectly so far. I have had to reduce the output to the lowest level 20% and most importantly I haven't had to lug any jugs of bleach!!! Hope it continues working this well