Pentair IC40 Red Low Salt Light on... Salt Not Low. HELP

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
29,710
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
here you go.

J1 com2 seems to run to heat pump
J2 com1 runs to the Screen Logic switch up in the attic
J3 com3 runs to SWG on J20 on main board

i also included pic of control panel showing lights and laminars on their switches

You said your ScreenLogic has not worked for years. I would disconnect the SL form J2 in case it is interfering with the Intellichlor.

Then I would move the SWG from J2 to J3 to see if it gets things working.

salinity is around 3500 using both a lamotte digital probe and and taylor salinty test kit. they are within 100-200 of each other

JamesW is trying to see what the SWG thinks the salinity is. You know the actual salinity you measure. We need to see what is displayed to have an idea what the cell is calculating the salinity to be.
 
Last edited:
  • Like
Reactions: JamesW

JamesW

TFP Expert
Mar 2, 2011
28,291
salinity is around 3500 using both a lamotte digital probe and and taylor salinty test kit. they are within 100-200 of each other
We need to know what the salinity reading is from the cell.
J2 com1 runs to the Screen Logic switch up in the attic
What switch?

Disconnect everything except the SWG from the com ports.

If necessary, reboot by powering off for 5 minutes and then back on.
 

acgibson

LifeTime Supporter
Aug 26, 2014
90
Olney / IL
You said your ScreenLogic has not worked for years. I would disconnect the SL form J2 in case it is interfering with the Intellichlor.

Then I would move the SWG from J2 to J3 to see if it gets things working.



JamesW is trying to see what the SWG thinks the salinity is. You know the actual salinity you measure. We need to see what is displayed to have an idea what the cell is calculating the salinity to be.
I cant get it to come up on the easy panel diagnostics or the inteliph control. is there another way to check? I will be glad to try lol
 

acgibson

LifeTime Supporter
Aug 26, 2014
90
Olney / IL
We need to know what the salinity reading is from the cell.

What switch?

Disconnect everything except the SWG from the com ports.

If necessary, reboot by powering off for 5 minutes and then back on.
The switch is that little control box or whatever it is that came with the screen logic that plugs into the internet. I will disconnect heat pump and screen logic when i get home
The RS-485 data connection is the way the cell communicates with the world.
lol... i have no idea what that is.
 

acgibson

LifeTime Supporter
Aug 26, 2014
90
Olney / IL
We need to know what the salinity reading is from the cell.

What switch?

Disconnect everything except the SWG from the com ports.

If necessary, reboot by powering off for 5 minutes and then back on.
1625004597369.jpegSo I removed the other 2 and powered down for five minutes, also left breaker off to hear pump just to be safe. No luck here either
 

acgibson

LifeTime Supporter
Aug 26, 2014
90
Olney / IL
New development. Pool guy just stopped by with the power center for the SWG to eliminate the easy touch center. It works fine with by both itself and the intelliph. So it’s something the easy touch controls. So at least I have chlorine going again while we try to sort out main issue.
 

Attachments

  • FB0C0B3F-7162-4A7A-839D-8D33FBCEC5BF.jpeg
    FB0C0B3F-7162-4A7A-839D-8D33FBCEC5BF.jpeg
    357.8 KB · Views: 8
  • Like
Reactions: JamesW

JamesW

TFP Expert
Mar 2, 2011
28,291
Try running a com cable from the new power center to the Easytouch.

Use a new 4 wire.

If that doesn't work, try it with the red and black wires disconnected and only the yellow and green wires connected.
 

Enjoying this content?

Support TFP with a donation.

Give Support

acgibson

LifeTime Supporter
Aug 26, 2014
90
Olney / IL
Is the Easytouch in Service mode or Auto mode?

Can you change the chlorinator settings when the Easytouch is in Auto mode?
in Auto mode.

No i dont believe it ever could really. When the screen logic worked first year, it would. I added the intelliph a couple years after and have always just controlled it from there.

My pool guy is great, but we are in a rural area and most do not put in lots of automations on their pools. So he doesnt have a lot of experience trouble shooting the easy panel systems or screen logics, and the nearest pentair rep in 2 hours away so he cant ever get them over this far. So most of this fancy automation i bought has never really been used because whenever something breaks getting repairs or troubleshooting is incredibly difficult.
 

ktb-ra

New member
Jul 6, 2021
1
houston,tx
I know, it has us stumped which why I’m reaching out here hoping some vets may have seen it before. As of right now, Pentair reps are supposedly looking into it.
Pics attached…
Could the two sharp 90's before the inlet be causing a weird problem (cavitation, etc.)? I thought it was recommended to have about 12 inches of straight pipe before the inlet side. What does the outlet side plumbing look like? Can't tell from this picture.
 
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread