Pentair Easytouch 8 - No communication with Wireless Controller (UWC)

JoKeRz42o

New member
Jul 20, 2015
1
los angeles, ca
I have an Easytouch 8 setup with a wireless controller(UWC) and one wired controller (UIC). All were setup/installed in 2016. The controlled did have a spill into the spa and it was replaced under warranty (only the handheld remote portion, not the wired antenna). I don't know if that matters but I'll get to why I mention it below.

1. Anyways all was working perfect until about a month ago when I came home and noticed the backyard lights, which are wired to a relax under AUX4, cycling on and off every few seconds... nonstop. During the troubleshooting some of the things I tried included a system reset, power cycled entire system from breakers, cleared EEPROM, etc.

2. I believe after clearing the EEPROM the communication between the wireless remote and the easytouch 8 system was reset. Since then I've tried unsuccessfully to relink the two. When I initiate the wireless address sync from both the remote and the outdoor controller, they both seem to be attempting a link but the address/connection is never made... and eventually the wireless controller times out and goes off. Even if I keep it on for over 5 min, no communication is established.

After extensive troubleshooting, through process of elimination and the fact that the two issues mentioned above occurred simultaneously, I was fairly convinced my mainboard/pcb was bad and needed to be replaced, so I simply disconnected the relay wire to the back of the board to prevent damage to the relay and more importantly my lights.

While shopping around for a replacement I came across the Screenlogic Interface and Wireless Connection Kit priced just north of $100 BRAND NEW SEALED BOX which I jumped on. Anyways, during install of the aforementioned, I disconnected the connector for the wired indoor controller (UIC) and to my surprise the indicator light to AUX4 stopped cycling on and off. Since then I've removed the Indoor controller and the AUX4 cycling on and off issue disappeared and I've been using a phone and/or tablet to control the system wirelessly. This made me reconsider the need to replace the Easytouch 8AUX mainboard since PROBLEM #1 was POSSIBLY being caused by a faulty INDOOR Controller. This left me with PROBLEM #2, a wireless controller not communicating and unable to lock an address with the OUTDOOR Control. This is where my mention of the replaced wireless controller MAY shed some light on my issue. I recently checked the firmware version of both the UWC and UOC and I realized they don't match up. The Wireless Control is 2.15 and the Outdoor Control is 2.13.

Could someone tell me if the firmware has to match for them to establish connection? If so, how has it worked up until now and why is it no longer working. On the other hand if the firmware versions don't necessarily have to match up, does that mean I do in fact have a faulty mainboard?

Please let me know if there's any further info/specs/details I may have miss or is required to properly diagnose.
Thank you in advance for taking the time to read and respond to my post!
-Harry

ADDENDUM:
I just remembered something I forgot to note above... While I was having PROBLEM #1 with AUX4 cycling on and off by itself, my VS IntelliFlo pump was having trouble communicating properly with the UOC. It would sync time but none of the set schedules would run. The pump would simply power on but no speed info would be received by pump. After removing the problematic UIC this issue was also cleared up.
 
Last edited:

ogdento

Bronze Supporter
Mar 30, 2015
579
Chico, CA
Hey Harry,
I've run different firmware versions on the outdoor board and wireless remotes and haven't seen any connection issue. (in the post you mentioned in the pm, I did set up a 2.16 and 2.13 and it worked)

It sounds to me like your transceiver card might have a problem... there are plenty of other posts here about troubleshooting comm problems but basically you want to try connecting with JUST your wireless transceiver connected to the comm port (disconnect the pump, indoor controller etc.). And be sure to power down the system first before you go pulling any wires off... especially if you're unscrewing them from the terminals rather than pulling the terminal blocks off the board.

Tom