Pentair Easy Touch Freeze mode not operating Cleaner

ccoffey

New member
Dec 24, 2020
4
Allen, TX
Pool Size
12000
Surface
Plaster
Chlorine
Liquid Chlorine
Hello, and Merry Christmas to all!

I just upgraded from a Compool 3400 to Easytouch using the Compool to Easy Touch upgrade, and added Screenlogic. Being able to control from my phone is absolutely aswesome. However, I have been running into issue with the freeze mode and valve actuation of my cleaner valve.

My pool is very simple (see attached diagram). But either I am doing something wrong, or my new controller has a fault. I have tried every possible combination I can think of and no matter what I do, I cannot get it to work the same way as the Compool did (all 3 actuators in my system in lock step with each other irrespective of freeze conditions). The cleaner actuator is connected to Valve B, and I have only one single speed pump in the entire system. It works flawlessley with manual operation (if I set Valve B to "spa" or to "Master Cleaner"). But when freeze happens, the 15 minute cycling does not cycle the cleaner valve, resulting in either draining the spa partially during spa freeze mode, or locking off the actuator entirely, leaving non moving water in the cleaner pipe/filter.

I live in far north Dallas, and freezes in the winter are common, though usually not very hard frezes, however there are some days where we have super hard freezes for many days in a row that I fear would freeze the cleaner pipe/filter. Obviously I could handle this manually during these rare events, but I'd feel safer if I could just get this darn thing to keep water moving during any freeze condition.

The attached PDF has my thoughts and troubleshooting all laid out, so any help would be greatly appreciated!
 

Attachments

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
20,162
Bedford, TX
C,

As far as I know, the 15 minutes freeze on/off is only between the Pool and Spa modes... Anything else will turn on with freeze but just stay on.

I don't fully understand your problem.. Just leave valve B set to come on anytime you are in the Pool mode and DO NOT set it to on with freeze.. Valve B should still come on anytime the Pool mode was on and that would include when in the freeze mode.

:scratch:

Thanks,

Jim R.
 

ccoffey

New member
Dec 24, 2020
4
Allen, TX
Pool Size
12000
Surface
Plaster
Chlorine
Liquid Chlorine
Thanks Jim, what you said is what I tried (page 4 of my attachment ), but if I set it to Pool mode, the valve never turns on at all - it is completely unresponsive between pool and spa modes and just stays on, regardless of manual setting or freeze condition. Makes me think something is wrong with the controller. Seems more like a software issue though because the valve can be controlled in other modes, but I have the latest firmware. I guess I'll have to try calling Pentair.
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
20,162
Bedford, TX
C,

So I have a spare actuator and ran a few tests...

I put the spare actuator on Valve A port.. and set the Valve A as "Pool"...

I then switched between the Pool and Spa mode and found that Valve A would turn one way in the Pool mode and the other way in the Spa mode. Just how you would expect it to work.

I then stuck the air temp probe in a glass of ice and water to force freeze control to come on. Freeze control came on as expected..

The pool switched between the Pool mode and the Spa mode every 15 minutes... as expected.

But... Valve A never moved.

So, as you had already deduced.. When in the freeze mode, the only valves that will switch every 15 minutes are the Intake and Return valves.

Does not make a lot of sense why that is, but I can tell you it is a "feature" and not a problem with your specific EasyTouch.

I suggest that you move up to this Century and get a Robot cleaner... :mrgreen:

Thanks,

Jim R.