One jet suddenly not working in older recently dormant pool with new pump/filter/swg

Some background: We live in Northeast Florida. The pool is a 10k gallon gunite built around 1990. My dad just bought the house last year after it sat vacant for 3ish years. He had professionals install an all new variable speed pump, filter, and a salt water chlorinator a week and a half ago. On their advice he drained all the water, cleaned and acid washed the pool, and refilled it. The pump has been running for the past week and all four jets were working fine until this morning.

He insists this isn't the issue, but the only thing that's changed since yesterday is last night we tried the pool vacuum for the first time, but the circular piece you stick in the skimmer got stuck afterwards (we didn't realize you stick it on the skimmer basket and not directly into the hole, so the suction wedged it in real good). He was able to get the thing off this morning after making a hook thing to fit inside the hole and yank it out. But the pool sat all night with the circular thing inside the skimmer (instead of the skimmer basket).

He says that the skimmer is a separate line, that its the water going into the pump, and the jet that's clogged is the return, after the pump, filter, and swg, so it has nothing to do with it, but up until this happened the jets were all working so I don't know what to think.

Also yesterday he added stabilizer which I know goes into the skimmer. He says he did it according to instructions so it shouldn't have clumped and blocked anything. We also turned the swg on for the first time yesterday, but only to 10% because its a t-15 cell and it's not a very big pool and we are still trying to figure out the proper setting without over chlorinating.

He's tried sticking a hose into the jet and nothing came out but a tiny little bit of dirt. He even made a seal around the hose with some pipe fittings and said the water wasn't going anywhere, that it seemed blocked? That the hose stopped putting out water cause the pressure backed up I guess? I don't know honestly what he meant by that.

But he just now tried using a snake and got all 20 feet into it, said it was difficult like it seemed there was blockage? But he got all 20 feet in and pulled it out and nothing was attached to the snake. He turned the pump on full blast and still that one jet isn't working.

I'm attaching a photo of the pool to show which of the jets it is, so you can see how close it is to one that is working. It's probably 20 feet or so from the jet to the pump house which is just to the right of the screen door in the photo. The red circle is the bad jet, and the green box is the skimmer.

The water level hasn't gone down any so he doesn't think the pipe inside collapsed. But any thoughts or suggestions on what to do or try is greatly appreciated.


Actually I'm gonna attach a second photo of inside the pool house to show the setup of the pump and filter and swg. I just read somewhere that it could be a valve is turned a little so that the full flow isn't going out, but there's no valves on the return line, just the line going in.



Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
Bedford, TX

Welcome to TFP... A Great resource for all your pool questions... :shark:

You generally don't put eyeball returns close to each other, so the one in red appears to me to be out of place. But no way I can tell for sure..

Your maintenance guy is correct that your vacuum was on the suction side and that whatever happened there, has nothing to do with your return problem.

I'm puzzled by your suction side valves... If you only have one skimmer then your gray valve selects the skimmer on one side and main drain on the other side, so what does the red valve control.
My guess would be a suction vacuum port, maybe the one in red??? Maybe something else... Do you know what it is for?

The only way your maintenance guy could have caused this would be to have dropped something in the main return line while installing the SWCG.

Please let me know what the red valve controls.

Thanks for posting,

Jim R.
Wow okay, so you're absolutely right! That red valve is for that "jet" which is actually a nozzle that you can attach a vacuum hose to. I was wondering why that one was able to be unscrewed while the other three seemed to be cemented directly into the wall.

I'm still puzzled however why up until today we've seen water coming out of that "jet". Or is it not possible and maybe I'm just confused and thought all four were working? I would have sworn tho that water was coming out of there up until today because when we reach down to get water for the tests I kept kneeling by it and then moving over because it says not to grab water next to a jet. But again maybe I'm wrong and it never was...

So now dad has a different question, when he turns the grey valve so the main drain is off but the skimmer is on, and turns the red valve to turn on the vacuum jet, there is still a slight bit of suction in the skimmer. Is there something we should buy that goes in there to plug it up temporarily? It doesn't feel like the suction from the vacuum jet is very high, not like the suction from the skimmer yesterday when we were trying to vacuum. Tho I guess we know why we got that piece stuck in the skimmer since this skimmer isn't meant to be used as a vacuum.

Here's a photo looking directly down into the skimmer, if that helps answering whether there's something we should buy that can plug it up while we vacuum.


But thank you for your quick response! Now dad doesn't have to buy a 40 foot snake LOL

also sorry for the gigantic pictures. no idea how to make them smaller :/