Omnilogic relays failing after update of firmware

tap1936

Active member
Apr 26, 2016
25
NJ
I upgraded my Omnilogic panel today to the latest firmware. The MSP went through fine but while upgrading the MPP's firmware it did not go through and failed mid way. Now, the MPP doesn't show up in the config, I have a Ecostar VSP and a sense and dispense connected to the same board and that is recognized by the MSP and I am able to control it. However, none of the relayes, valves, sensors are being recognized.

I am not understanding how portions of the board could work and some of it not. According to the docs I have seen, the 12V and 24V led's are lit. The Micro Led is on off every second, it doesn't seem to be the 6 seconds I read in the docs.

I called Hayward support which was pretty much useless and they want an authorized service person to come and take a look at it at my expense. Not sure how an update to the firmware should cost me anything.

I did reset the settings clearing the DDT as suggested in the manual. No luck with that.


Any suggestions? I am very handy with electronics and the electrical side.

Thanks in advance

RS
 

guinness

Well-known member
May 3, 2019
88
California
I'm not familiar with the OmniLogic is the update done via a USB? The firmware image might've been corrupted. Can you remember what the error message was when the MPP update failed? Are you able to reapply the firmware update again or is it not letting you? If you can, you might try to drop back to an earlier firmware version. A last resort would be trying a factory reset, but I'm not sure that would help.

I assume the Troubleshooting Guide is the docs that you referred to. How long have you had the system and is it still under warranty? I would try calling Hayward technical support again you may get someone more helpful next time.
 

tap1936

Active member
Apr 26, 2016
25
NJ
I am not able to apply the firmware update again because now the Main panel is not visible. I have tried reverting to the previous firmware as well that didn't help either. Have tried a factory reset as well.
thx
 

JLayer01

Member
Jul 23, 2017
20
Brazil/Indiana
Is it just the files that aren't visible when trying to update it? I did this last night. I got to the option of upgrading the MSP and MP. Once I hit the MP, it gave me a USB/ but none of the files were showing up and they did previously on the MSP. If you downloaded the files in Internet explorer to the USB, you have to delete the .txt at the end of the file. It will be visible after that on the main display. I went nuts on this trying to figure it out but noticed on one of the instruction pages, it says at the very bottom to use Chrome/Firefox/Safari to download the files. If using the IE, you have to delete the .txt.

Hope that works for you.

I'm still trying to figure out how to get the OmniDirect to work like it states in the upgrade.