Oasis Z5 Question - Stuck on bottom grates

iceskier

New member
May 23, 2014
1
Minneapolis, MN
#1
I just got my Maytronics Oasis Z5 running yesterday and within 5 minutes of being in the pool, it got stuck on one of the bottom grates. Anyone have a similar problem with the Z5 or another Maytronics product? Would anyone have a suggestion for a grate with a smaller stack height? I really don't want to return the unit, but also do not want to stand around watching to see if it hangs up either. Thank you for the help
 

Patrick_B

TFP Expert
LifeTime Supporter
Jun 7, 2011
14,999
Midland TX
#3
Hey Ice, Welcome to TFP!

I just got an M5 and its pretty much the same unit. I'm sorry, but this has not been any kind of issue at all with mine. Your grates/covers must really stick up pretty high do they?

Are you able to drive him off with the remote? If it keeps happening, it sounds like you may have to change the grates if that is possible. I am sure that unit performs as well as mine and it is a dream machine. I'd hate to see you not find that out with yours. I would call Epic, and see what they have to say. I'm sure they would be helpful.
 

TWong1200

Active member
May 6, 2014
42
Corona, CA
#8
Good question....I hadn't thought about that. Perhaps that's why? Even if I had it on, I have my main drains off and slimmer only.

Sent from my Nexus 5 using Tapatalk
 

Mike_k

Gold Supporter
LifeTime Supporter
Apr 16, 2012
119
Mason, Ohio
#11
I had the same issue with my new Z5. I just ordered some Main Drain Clip-ons from http://stores.maindrainclipon.com. The site has some videos showing how to install - looks pretty easy. Seems like they should work. I'll report back after I receive them.
So far the results are disappointing. The video makes it look like they are very easy to install. The problem is the guy is four feet away and working out of the water. When you're 12 feet away, working through 8 1/2 feet of water - not so easy. Even though my water is crystal clear, it's hard to see the end of the clip and hard to line it up with the first hole. When it is lined up, the action of snapping it in with a 12 foot pole is very hit or miss. Mostly miss. It doesn't help that every time you move the pole it creates ripples on the surface of the water, making it even harder to see. I was able to get one on but broke another. I'm going to have to have my son swim down and attach the others manually.

I planned to attach two to each drain cover. I decided to see how it goes with just one, and it doesn't appear to be making any difference. My Z5 has gotten stuck on that drain five times already.

I will look into the smart ring as well. Thanks laprjns.
 

Mike_k

Gold Supporter
LifeTime Supporter
Apr 16, 2012
119
Mason, Ohio
#14
Mike, do you have any pics of your main drains? I'm curious as I don't want to deal with this problem.

do they look like this?
Sorry - just saw this! Yeah - mine look like yours, sort of:



I came here to post an update on the main drain clip ons. As I said above I was able to successfully attach one of the clips. I ran the Z5 - it dislodged the clip and sucked it up. Dolphin 1, clips 0. It was an impressive move on the Dolphin's part, though. I still plan to install the clips by hand and try again, but I'm not too hopeful. I tried running the Dolphin tonight without the main drains on, but it didn't make any difference. It still got stuck 5 or 6 times. It sounds like the third brush in the M5 makes a difference.
 
Jun 29, 2014
6
Rochester, IL
#15
I have Z5 also with exact problem, very disappointing, no fix that I can find and no help from sellers. At least my old Tiger Shark had an add on piece you could attach to robot to resolve the problem.
 

Patrick_B

TFP Expert
LifeTime Supporter
Jun 7, 2011
14,999
Midland TX
#16
I have Z5 also with exact problem, very disappointing, no fix that I can find and no help from sellers. At least my old Tiger Shark had an add on piece you could attach to robot to resolve the problem.
You've made this statement three different times including this post. The first three posts you've made on this forum were with this statement.

The answer to your problem is in at least two of these threads. The main drain covers seems to be the answer to the problem for everyone having this issue.

As for Epic not answering or getting back to you, I can't say, but they were helpful to me when I was shopping for a cleaner, and as far as I know, good with other purchasers of Dolphin products.
 

Mike_k

Gold Supporter
LifeTime Supporter
Apr 16, 2012
119
Mason, Ohio
#18
The answer to your problem is in at least two of these threads. The main drain covers seems to be the answer to the problem for everyone having this issue.
I think that I've seen all of the threads on this issue, but I've not seen any posts discussing main drain covers that are solving the problem. I see one post that refers to a "smart ring" - is this what you're talking about? If not, can you point to those posts? Thanks!
 

MBG75

LifeTime Supporter
Jun 15, 2013
184
Long Island
#19
I just ordered 2 Polaris unicovers. Should have them Wednesday to install.

My dolphin was constantly hanging up on my drains. Filter on or off.

Will post back how they work.
 
Jun 29, 2014
6
Rochester, IL
#20
Would it be possible for you to post a picture or link for this part?
Thanks
Sure, it's just a sloped raised piece that clips onto suction hole/slit on bottom, never got stuck after this addition, however this is my 'backup' robot and needs some work to get working good again since older machine that's been borrowed quite a few times.
 

Attachments