No power on Pentair IC40

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
26,520
Bedford, TX
Ant,

The breaker would trip if ..

The breaker is bad.. (cheapest part to replace)
The surge card is bad, drawing too much current (next cheapest item)
The Cell is bad, drawing too much current. ($$$ Och!!)

Thanks,

Jim R.
 

Dirk

Gold Supporter
TFP Guide
Nov 12, 2017
9,901
Central California
Pool Size
12300
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
Replacing your IntelliChlor only to find out it wasn't bad isn't the worst thing. You use the second one first, until its warranty expires, then either continue to use it until it's done, or go back to the first one. You'll have a backup until one of them is finally finished, and then the backup one can come online. They're expendable. Not unlike buying extra gallons of chlorine, except the chlorine "stored" in an SWG doesn't go bad.

And while SWG prices might come down after supply chain issues resolve, I'm guessin' they won't. Now that corporations know we'll pay these prices, there's not a lot of incentive for them to give them up. It's more likely SWG prices will continue to rise, and you'll have a "bargain" in storage.

I replaced an IntelliChlor that had some issues, even though it still makes chlorine. I replaced it while under warranty, while I could. I'll reinstall the old one when the new one is done, and in the meantime I have an "emergency" SWG waiting in the wings.
 

antoniosp

Well-known member
May 14, 2013
158
austin/texas
My 1st SWG stopped working 2 years ago, after a 6 year run, so this is the 2nd one I was given originally for free. I just checked again and after working for few hours, the 12amp fuse was tripped again. So seems like I may indeed have a faulty SWG and should get a new one. and keep current one as backup.
I agree with the pricing , supply chain/no more virus or not prices will not come down.
 
  • Like
Reactions: Dirk

Dirk

Gold Supporter
TFP Guide
Nov 12, 2017
9,901
Central California
Pool Size
12300
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
My 1st SWG stopped working 2 years ago, after a 6 year run, so this is the 2nd one I was given originally for free. I just checked again and after working for few hours, the 12amp fuse was tripped again. So seems like I may indeed have a faulty SWG and should get a new one. and keep current one as backup.
I agree with the pricing , supply chain/no more virus or not prices will not come down.
Then if the new one still trips the breaker you'll know both your ICs are probably OK.

I lost track, did you swap in a new breaker yet? As Jim pointed out, that's the cheapest troubleshooting step. Well actually, not the cheapest. I just had a quick look, are those things like $25+??

If you're handy, and cheap, and inclined, you could quickly (temporarily) wire in a 12A auto fuse (bypassing the Pentair breaker) and see if that pops. If it doesn't, you likely have a bad breaker, if it does, then maybe your breaker is fine and the problem is downstream... You might find a fuse like that for a few bucks at your local auto parts store...

Just for reference: My surge board (which didn't come with my EasyTouch, but rather came out of the Pentair Power Center power supply for IntelliChlor) has an auto-type fuse on it. It's a 10 amp fuse. I have an IC40, and it's never popped that 10 amp fuse, even though my IC melted a connector similar to the one you had that fried.

Screen Shot 2022-04-12 at 11.08.51 PM.png
 

antoniosp

Well-known member
May 14, 2013
158
austin/texas
I ordered a breaker switch also, they are about $65 so not that cheap for what they are.
I am waiting for both items to arrive and will install one at a time. Even is the SWG is not bad I will keep the new one since eventually it will go out. Will post once I have updates.
Thanks everyone again for al the support and help!
 
  • Like
Reactions: Dirk

Enjoying this content?

Support TFP with a donation.

Give Support

antoniosp

Well-known member
May 14, 2013
158
austin/texas
I installed the ic40 first and will wait to see. I started getting the clean cell error also on my panel even though cell had no calcium buildup so thought one more reason cell is bad. Will post updates after monitoring for couple of days.
 
Last edited:
  • Like
Reactions: Dirk
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread