New skimmer not working

Rsummers11

New member
May 9, 2017
3
Columbus, IN
Hi! I have a 16' round Intex above ground pool with a 1200 gph sand filter attached. I bought the skimmer for it and put it on the pool today and it does nothing :mad:. Leaves and debris just wash around it. If I disconnect the hose and put my hand over the intake I feel really good suction. I can also see the water moving across the surface coming through the output but there is absolutely no suction or draw to the skimmer at all. I have backwashed my filter. I have ensured there is no air in any of the hoses. I'm lost. The required gph for the skimmer is 800 gph. Any ideas on what I need to do?

Thank you!
Renea
 

jblizzle

Mod Squad
TFP Expert
LifeTime Supporter
May 19, 2010
41,195
Tucson, AZ
:wave: Welcome to TFP!!!

Can you post a picture of what skimmer you added?
If it does not have a weir door on it, then it is not going to pull much across the surface.
 

jblizzle

Mod Squad
TFP Expert
LifeTime Supporter
May 19, 2010
41,195
Tucson, AZ
Hmm, well I have no experience with those, did not realize it was not a through the wall skimmer. How someone else can jump in.
 

domct203

Bronze Supporter
LifeTime Supporter
TFP Guide
Jun 3, 2015
3,959
CT
Best thing I ever did was ditch that Intex skimmer and install a thru the wall skimmer (see my signature for link to skimmer install).

Next best thing I did was get a larger filter.
 

Rsummers11

New member
May 9, 2017
3
Columbus, IN
Best thing I ever did was ditch that Intex skimmer and install a thru the wall skimmer (see my signature for link to skimmer install).

Next best thing I did was get a larger filter.

Thanks Dom👍🏻 That is my next step. I'll check out the link. One more question, what would you recommend for a filter upgrade? Mine is sand and circulates 1050gph.
 
Thread starter Other Threads of Interest Forum Replies Date
J Swimming Pool Start-up and Closing 9
N Pumps, Filters, and Plumbing 7
the_sphynx Just Getting Started 8

Other Threads of Interest