New pool, spa jet pump lost prime and won’t prime

johnkim2020

Well-known member
Aug 2, 2020
66
Canada
Hi,

new pool installed. Spa jet has 1hp Pentair Superflo dedicated to four jets. The spa jet suction and return are isolated from the rest of pool plumbing. No check valve.

PB primed the Superflo and spa jet is working last week. I haven’t touched it since then and now it won’t prime.

Pump is uphill from pool.

when I filled water to strainer basket, water just flows back to suction and eventually, the pipe becomes empty. I tried to fill multiple times and ran pump for 1-2 mins each to prime, no go.

Questions:
1. Is it normal to lose prime after extended period (3+days) of pump shut down?
2. If #1 is true, since spa jet is not frequently used, how do I prevent it to lose prime? Turn it on once a day? Change plumbing?
3. How can I fix this? Call PB to reprime it?
 
Last edited:

johnkim2020

Well-known member
Aug 2, 2020
66
Canada
The pump should not drain down. I suspect the pump basket lid gasket needs to be lubricated and the lid securely tightened.
Hi mknauss,

Thanks. If pump was primed and working a week ago, it should not lose prime after a week of non operation even pump is shut down?
 

johnkim2020

Well-known member
Aug 2, 2020
66
Canada
No. If there are no leaks in the system, the pump and system will stay full of water.
Thanks. If the pool guy said “it will lose water slowly if you don’t turn on the pump regularly”. Is he full of it?
 
Last edited by a moderator:

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
43,966
Laughlin, NV
Thanks. If the pool guy said “it will lose water slowly if you don’t turn on the pump regularly”. Is he full of it?
If left for months, it will lose water because no pool system is that perfect. But overnight, it will stay full.
 
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.