New Pool Plumbing: Bubbles and low flow through skimmer. Good pressure through pump hose.

poolschpool

Member
Jun 12, 2019
14
Fremont, CA
Hi,
I have a newly replastered and replumbed pool with brand new Pentair Whispreflo pump and Pentair Clean and Clear Plus filter.

When I filled the pool and turned on the pump, I get intermittent flow of water and it makes a gushing sound with a lot of bubbles every once in a while. The pressure gauge on the filter is at 0 and I do not get any water when I open then Manual Relief Valve on top of the filter

On the other hand when I connect a vacuum hose to the pump link in the skimmer, I get good flow with strong pressure stream. The filter gauge shows pressure of 3psi and I get steady flow of water when I open the manual relieve valve.

Why is the system behaving like this. Is this an issue with the skimmer. The skimmer has the float with diverter valve set to open.
 

cowboycasey

Gold Supporter
LifeTime Supporter
TFP Guide
Jul 3, 2013
4,319
Fletcher, OK
There is not enough water in the pool to make the skimmer work... is the water 3/4 of the way up the skimmer? is the weir moving freely to allow water through? If my water gets too low it will do the same thing...
The skimmer has the float with diverter valve set to open
Not sure what you mean here, are you talking about the weir/door? can you post a picture? :)
 

poolschpool

Member
Jun 12, 2019
14
Fremont, CA
An update from my side. The Installer was here today and he said that since my pump is a few feet higher than the pool, we need a check valve to prevent any air gaps from forming in the system.

I hope this will solve the issue.

1599156689939.png
 
  • Like
Reactions: cowboycasey