New Modem Causing ScreenLogic Connection Issues

Matchless1

Well-known member
Jul 10, 2014
294
Baton Rouge, LA
I'm having a very similar issue as the one in this thread. My new modem caused my router IP address to change from 192.168.1.1 to 10.x.x.x. Many other devices (i.e. irrigation, surveillance DVR, Apple TV, weather station, etc.) all re-connected after resetting those devices, but my ScreenLogic brick will not. It seems to still be stuck on the old IP address. I want to go in and change it, but the "Configure IP Info" button is greyed out for me, so I can't fix it. Tried resetting the brick many times, even tried using some old bricks I have. Tried uninstalling ScreenLogic, then reinstalling. Tried running as admin. I'm at a loss here.

The attached screen shot is what I get when clicking the "Configure ScreenLogic" button.

Any suggestions on how to enable the "Configure IP Info" button?
 

Attachments

  • Configure IP Info.jpg
    Configure IP Info.jpg
    78.8 KB · Views: 10

Dirk

Gold Supporter
TFP Guide
Nov 12, 2017
8,440
Central California
Pool Size
12300
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
That linked thread has SL Adaptor resetting instructions different from what I've read here elsewhere. Something about pressing that reset button three times. I would try that, see what happens. Maybe press it three times. Unplug everything from/to it. Wait 10-30 seconds. Reconnect everything. Press reset three times again, for good measure. All this with ScreenLogic software quit/closed. Then start up SL software and see if it can find the Adaptor.

The "Configure IP Info..." button becomes active when you can select (click) a System in the "Local Systems" field. That becomes available only after the software recognizes the Adaptor.
 
Last edited:

Matchless1

Well-known member
Jul 10, 2014
294
Baton Rouge, LA
Thanks Dirk. I ended up plugging in the brick to a LAN port on the new modem/router combo, logging onto that router's WiFi, then restarting the ScreenLogic app. At that point, it recognized the brick on the old IP address, so I could select it and reconfigure the IP info with the new IP address, subnet mask, etc. Of course immediately after I did that, it lost the connection to the new router, which I expected it would. Then I plugged the brick into the main/old router port, logged into the main router/old WiFi, restarted ScreenLogic, then it recognized the brick on the new IP address. And we all lived happily ever after!
 
  • Like
Reactions: Dirk

Dirk

Gold Supporter
TFP Guide
Nov 12, 2017
8,440
Central California
Pool Size
12300
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
Glad you got it working! (y)
 
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.