New Install of Omni Hub - AquaRite Integration?

zcast

Member
May 15, 2020
5
Florida
Hello Everyone, New Member here.

I am planning out my pool system upgrade and I have a question someone might be able to answer for me.

I purchased a Hayward MaxFlo VS 500 Omni to replace my old single speed Jandy. I currently run a SW system with Solar with no Hot Tub, just a fountain. The Omni kit with the pump comes with one Smart Relay, the base and the controller.

From what I can tell from the manuals, the OmniHub can control 2 valves (On my system that will be Solar and Fountain), it will control my pool light via the smart relay provided, the current Pentair SolarTouch controller will be removed and the temp sensors will be tied into the Omni.

Since I have a Hayward AquaRite system with a T-Cell 9 installed, I read the OmniHub can control the AquaRite with the additional communication board HLAQRPCB. So I went ahead and purchased this part so I had it for the installers when they arrive, but for the life of me I cannot find a manual on this part and how it gets installed. Does anyone have any insight into this? Does the flow switch on the AquaRite move into the OmniHub now, or does it stay in the AquaRite and the OmniHub reads it from there? I only ordered the PCB part, do I need anything else? Low Voltage cable? I know they sell an AquaRite system with the OmniHub and in that kit the PCB is included with everything you need, but if I am purchasing this separately, is the PCB all I need?

Thanks for your help!
 

PoolNewb2020

Well-known member
May 7, 2020
302
Lathrop, CA
That would be nice to know. I also have omni hub and Hayward's documentation is not exactly clear about installing the daughter board. It says to follow the instructions included with the board. I would presume it gets installed in the Aquarite panel somewhere.
Other than that the AquaRite manual only mentions getting a 4 wire low voltage cable for communication.
So it would seem, the omni hub should only need the daughter board and the cable.
 

zcast

Member
May 15, 2020
5
Florida
That was my impression as well, but somewhere there IS a manual and I for one would love to see it. I will reach out to Hayward to see if they can provide that for me. I am also curious as to what information the OmniHub receives from the AquaRite. Does it report back levels? Can you modify your output from the Omni now? Will it show messages like "Check Cell" and whatnot?
 

zerosignal

Member
May 7, 2015
10
NJ
That was my impression as well, but somewhere there IS a manual and I for one would love to see it. I will reach out to Hayward to see if they can provide that for me. I am also curious as to what information the OmniHub receives from the AquaRite. Does it report back levels? Can you modify your output from the Omni now? Will it show messages like "Check Cell" and whatnot?
Is this the manual in question?
 

Attachments

  • DD4D360C-E6C9-4E30-B8E6-F07D458CF4E1.jpeg
    DD4D360C-E6C9-4E30-B8E6-F07D458CF4E1.jpeg
    341.2 KB · Views: 52
  • 79AFCCE2-6C5C-4D62-9F0C-0C2C25E43BAB.jpeg
    79AFCCE2-6C5C-4D62-9F0C-0C2C25E43BAB.jpeg
    541.5 KB · Views: 56
  • 72B5B645-BCCA-41DD-BB33-1C9FE8E20BDE.jpeg
    72B5B645-BCCA-41DD-BB33-1C9FE8E20BDE.jpeg
    514.2 KB · Views: 51
  • 08A25F2F-C203-493A-BB36-B15B45056908.jpeg
    08A25F2F-C203-493A-BB36-B15B45056908.jpeg
    599.6 KB · Views: 45
  • 66A1F821-6A0C-407D-BAFE-35EF2C2B74D6.jpeg
    66A1F821-6A0C-407D-BAFE-35EF2C2B74D6.jpeg
    404.5 KB · Views: 43
  • FEE8ECF4-D004-44CB-BE26-94712E4DDF09.jpeg
    FEE8ECF4-D004-44CB-BE26-94712E4DDF09.jpeg
    471.6 KB · Views: 41
  • 8A093897-AD14-4629-ACA6-EBCE75B074F2.jpeg
    8A093897-AD14-4629-ACA6-EBCE75B074F2.jpeg
    391.4 KB · Views: 37
  • Like
Reactions: PoolNewb2020

PoolNewb2020

Well-known member
May 7, 2020
302
Lathrop, CA
Looks like this is it. Thanks for sharing, I bookmarked it for reference. Thinking of installing SWG in the future and having it automated through omnilogic would be the best solution.
 

zcast

Member
May 15, 2020
5
Florida
Received this manual today from Hayward support.
 

Attachments

  • AQR Daughter Board (HTG_AQRDBa).pdf
    869.1 KB · Views: 95

Krysib

Well-known member
Jun 18, 2020
75
League city TX
Hi Everyone,

Reviving this thread as it was instrumental in my DIY automation addition.

A little backstory, we built a #COVIDpool last summer and it was complete mid-August. We had been looking into SW, but the PB was against it and installed UV/O3 (.....prior to finding this forum, obviously as now I know that was a waste). We used liquid bleach method after startup, and mid-August in TX startup had us lugging a lot of jugs to keep up with demand. Over the winter we debated installing a SWG, and just bite the bullet last week. The PB was extremely unhelpful and when we asked if it could be added to our automation (VS omni, not omniLogic), they said NO. They also suggested we watched 'youtube' to learn how to work it. (Note to self, NEVER call them again..)

So after using this forum and the experts here, I knew I could try to make it work. I purchased the aquarite daughter board by calling Polytech and ordering it over the phone. It arrived in two days and hubs and I were out figuring out how to install.

It was extremely straight forward, but the hub where it is plugged into the Omni controller is jam packed with other cables (3 relays and pump cables), so we were slightly nervous we were going to mess up our other automation. After carefully inserting the new cables, we crossed our fingers and powered everything back on.

It worked perfectly and immediately! I took some real life installation pictures in case it helps anyone else.

Thank you to this forum and its members!
 

Krysib

Well-known member
Jun 18, 2020
75
League city TX
Install images attached here.
 

Attachments

  • 694B5788-6F6D-4B91-821F-580ACB896786.jpeg
    694B5788-6F6D-4B91-821F-580ACB896786.jpeg
    561.1 KB · Views: 11
  • B02BEBFF-752F-4609-9FCE-4D93AA5FEF12.jpeg
    B02BEBFF-752F-4609-9FCE-4D93AA5FEF12.jpeg
    324.4 KB · Views: 11
  • 92135BC5-317C-4063-8C8C-757AAB2057A6.jpeg
    92135BC5-317C-4063-8C8C-757AAB2057A6.jpeg
    401 KB · Views: 12
  • 983EAE0E-A6CB-406B-99C5-142CEB1E269F.jpeg
    983EAE0E-A6CB-406B-99C5-142CEB1E269F.jpeg
    332.9 KB · Views: 12
  • E2EDF4F5-B8FB-4328-805B-372EB092F6EC.jpeg
    E2EDF4F5-B8FB-4328-805B-372EB092F6EC.jpeg
    371.9 KB · Views: 12
  • B5609100-653F-493A-A657-7FC3C2964CA3.png
    B5609100-653F-493A-A657-7FC3C2964CA3.png
    477.5 KB · Views: 11

Enjoying this content?

Support TFP with a donation.

Give Support

zcast

Member
May 15, 2020
5
Florida
So the pool automation was setup last year and everything is working as intended. Maybe twice a year it loses connection and the Omnihub needs a reboot to establish a connection again. Overall I have been very pleased with the system, even with the Alexa integration. I still need to update to the latest firmware though.

All that said I do have a question that I will just post here rather than create a new thread since it does apply to the Omnihub. Currently my Omnihub is controlling my Maxflow VS pump, Hayward Chlorinator, two GVA-24 Valves (Solar Heater and Fountain), and the pool light. I am looking to add a third GVA-24 valve in my system but the Omnihub only has connections for two valve actuators. Now I believe the Maxflow VS pump can control a valve directly from the unit when an automation system is not being utilized. So my question is, can I wire a third GVA-24 Valve into the Maxflow pump and have the Omnihub control it?

Thanks,
 

JamesW

TFP Expert
Mar 2, 2011
23,482
I believe the Maxflow VS pump can control a valve directly from the unit when an automation system is not being utilized. So my question is, can I wire a third GVA-24 Valve into the Maxflow pump and have the Omnihub control it?
Why do you think that?

Where did you get that information?
 

Anthony Fisher

New member
Apr 7, 2021
3
Greensburg, PA
Hello! New member here looking for some help with the same situation as the OP. I have an Aquarite 900 and Omni-Hub. I purchased the daughter board for the Aquarite 900 and installed it per the instructions. The daughter board LED flashes every 6 seconds, the "remotely controlled" LED is lit, the primary/secondary jumper is installed, "AL-0" is displayed. I can not figure out how to program the Omni-hub to control the SWG. The Omni-hub installation manual that came with my equipment (092680 RevD) doesn't even mention programming SWGs. However, installation manual 092712 RevC (found on the interwebs) does discuss programming a SWG under "typical configurations". I can not figure out what I'm doing wrong. Thanks!!!
 

Krysib

Well-known member
Jun 18, 2020
75
League city TX
Hello! New member here looking for some help with the same situation as the OP. I have an Aquarite 900 and Omni-Hub. I purchased the daughter board for the Aquarite 900 and installed it per the instructions. The daughter board LED flashes every 6 seconds, the "remotely controlled" LED is lit, the primary/secondary jumper is installed, "AL-0" is displayed. I can not figure out how to program the Omni-hub to control the SWG. The Omni-hub installation manual that came with my equipment (092680 RevD) doesn't even mention programming SWGs. However, installation manual 092712 RevC (found on the interwebs) does discuss programming a SWG under "typical configurations". I can not figure out what I'm doing wrong. Thanks!!!
Check the operations manual (rather than install) as it might have pics to walk you through.

But.... you have to go into the configuration wizard using the touch screen and add the SWG on as a “chlorinator” option. Once I did that-it all worked beautifully.

As an aside-myself and another member have noticed that the omnihub has fewer controls/features through the app than Omni logic would. Once you get it working-would you let us know what you see on the app?
 

Anthony Fisher

New member
Apr 7, 2021
3
Greensburg, PA
I do not have an option to add a chlorinator in any of the config wizard menus (pre programmed, typical, advanced). The cover of my control panel doesn't indicate that there would even be a chlorintor option.


IMG-8013.jpg
 

Krysib

Well-known member
Jun 18, 2020
75
League city TX
I do not have an option to add a chlorinator in any of the config wizard menus (pre programmed, typical, advanced). The cover of my control panel doesn't indicate that there would even be a chlorintor option.

All options are not listed on the cover of the touch pad. Using the omnihub installation manual, go to page 49 where it describes the quick edit feature. Follow through to edit to add chlorinator which is listed under "chemistry' on page 52.

Quickly the steps are:
Config wizard
edit current configuration
bodies of water
pool
chemistry
add chlorinator type and cell type here (it should show up here if daughter board is correctly installed/connected)
save and restart control panel