need new laterals for Sta Rite Cristal Flo T210WF sand filter

flyweed

Bronze Supporter
Aug 3, 2009
524
SW Wisconsin
#1
Hey all, Last fall before closing our AGP, I notice that even after I cleaned our pool, a few hours later there would be A LOT of sand downstream of the return along the bottom edge of our pool. I would assume it's most likely a lateral or two, or more. Since this filter was used when I bought it, and moved it (full of sand) and installed it at my house....the laterals were not treated very well.

Anyway, can anyone point me to the CORRECT laterals I need for this filter: Sta-Rite Cristal Flo T-210WF? Also looking for best/lowest prices.

Thanks for any help

Dan
 

JVTrain

TFP Expert
Feb 3, 2014
5,080
Central Minnesota
#2
OP
OP
F

flyweed

Bronze Supporter
Aug 3, 2009
524
SW Wisconsin
#3
Thanks for the input. I have located the correct laterals...NOW......do I need them or not? I pulled my riser and laterals OUT of my filter today..I was fully expecting to see at least one or more broken. BUT...everything looks fine. why am I seeing so much sand on the bottom of my pool? I don't live in a sandy area, and my pool is surrounded by tree's that minimized blowing into the pool. Here area 3 pics I took of my laterals. Should I replace them anyway????? Any thoughts would be great.
 

Attachments

OP
OP
F

flyweed

Bronze Supporter
Aug 3, 2009
524
SW Wisconsin
#5
Ok...well I went ahead and ordered all new laterals..and installing them this weekend...HOPEFULLY that's the issue with the sand. Thanks for all the help! LOL :)
 
May 30, 2017
1
Boise, ID
#6
morning, sorry to ask a questions on an old thread but I need new laterals for the sand filter. Do you remember the part number by chance? And it looks from the pictures that I will need eight. Thanks again.