My digital controller on my PureLine Prime Variable Speed Pump has quit working

Major_in_MS

Gold Supporter
Jul 9, 2016
227
Florence, MS
Pool Size
24000
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Pureline Crystal Pure 60,000
In August of 2017 I installed a new variable speed pump from inyopools.com, the PureLine Prime Variable Speed Pool Pump 1.65 HP - PL2605

PL2605.jpg
Today the buttons on the digital controller stopped working. Has anyone seen this problem? Is it something I can fix without replacing the controller?

I called inyopools.com and they have a replacement for the controller, V-Green 270 User Interface - 2520652-001 for $229.99. It looks different, but they tell me it will work with my motor. If I order this part, will I need to order any seals or bearings or anything? Does the motor have to be removed from the pump to replace the controller?

newcontroller.jpg
 

markayash

Gold Supporter
Mar 21, 2016
3,508
Atlanta Ga
Following, I have the same pump. I would think it’s a simple install with power and a connector but not sure.
Is that the controller that works with the app? I know they had an additional part for around $200 but wasn’t sure if it was a daughter board or not.

On the board have you tried flipping the breaker off for 15 minutes and back on and see if it’s just locked up?
 

Major_in_MS

Gold Supporter
Jul 9, 2016
227
Florence, MS
Pool Size
24000
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Pureline Crystal Pure 60,000
Following, I have the same pump. I would think it’s a simple install with power and a connector but not sure.
Is that the controller that works with the app? I know they had an additional part for around $200 but wasn’t sure if it was a daughter board or not.

On the board have you tried flipping the breaker off for 15 minutes and back on and see if it’s just locked up?
No, this controller does not work with the app, I believe that would be the Century Motor VLink - VL100 for $294.99.

I did turn off the pump at the breaker, that is currently the only way I can turn it off to backwash. Turning it off had no effect on the controller. Good idea though.
 

laprjns

LifeTime Supporter
Aug 14, 2012
518
Ellington, CT
Pool Size
30000
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Pureline Crystal Pure 60,000
Regarding replacing the controller, there is one DIY review posted on that Inyo page that say it is an easy install. Also, did you check to see if the key pad got inadvertently locked out?
 
  • Like
Reactions: markayash

Major_in_MS

Gold Supporter
Jul 9, 2016
227
Florence, MS
Pool Size
24000
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Pureline Crystal Pure 60,000
Regarding replacing the controller, there is one DIY review posted on that Inyo page that say it is an easy install. Also, did you check to see if the key pad got inadvertently locked out?

That’s a good point, there is a way to lock it. I found some decent videos on YouTube regarding operation


Great, I missed that DIY review, glad to see it is a simple replacement and I don't have to break apart the pump/motor.

After watching that video about the lockout feature I was already sure that was not my issue because when locked the "stop" button is supposed to still function and mine does not. But, I went and tried it anyway, no luck. The keypad did actually work for about 15 minutes this morning before quitting again. I'm thinking I will take it off tomorrow and clean it out real good with some circuit board cleaner and seal the housing better to prevent water entry and check for shorts. I may be as simple as a loose ground wire I guess.

I wonder if the pump will still run with the controller disconnected, I'm in the middle of a SLAM right now. That replacement controller is out of stock right now and they are not expecting it to ship until the first week in July.
 

markayash

Gold Supporter
Mar 21, 2016
3,508
Atlanta Ga
There is a way to control the pump using the pins. Can’t remember but somebody did post a link. Seems like there were 3 or 4 and jumping from power to each one was a different speed.
If it’s running maybe leave it alone until your done with the SLAM
 
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.