Mustard Algae?

andysutt

Well-known member
Jun 8, 2007
88
Arkansas
#1
I've never seen or experienced mustang algae before... but I may have it.

I semi-neglected my pool for a few days and we had some big rain... went out and my pool was a greenish/yellow tint to it... kinda cloudy looking.

I test it, no chlorine in it... so I dump in 1/2 gallon of bleach and change filter and clean the dirty one.
I see what I thought was pollen on the bottom so I stir it up w/ my pool net and help out the circulation... I let it run another couple hours and change filter again and add the rest of the 1/2 gallon of bleach.

I know this is overkill on bleach but I wanted to be safer than sorry.

I have tested the PH and it was fine also.

I have a 6 way test kit but only used the test for the ph and chlorine.

Ph is staying fine, and the bleach level stayed maxed on the scale overnight so I didnt add anymore bleach but changed teh filter... the water started to clear up greatly. Last nite my mother got into the pool to net out the remainder of the "pollen" and stir it up and get all the leafs out of the pool.

Today I come home, go outside and the pool is once again the cloudy color.
I test the Ph and the CL levels and the CL isnt maxed otu but close to it on the scale and the PH is fine at 7.5ish as usual.

I add another 1/2 gallon of bleach, again knowing that it is overkill and I change the filter and clean the dirty one.

Any idea what this is and how to get rid of it?
 

DavidD

Well-known member
Mar 29, 2007
91
#2
Sounds like it could be Mustard Algae. The solution is simple :roll: . Vacuum all you can to waste (if possible), adds lots of chlorine, hold it as precise as possible and consistently high for at least several days. If you'd like more detailed advice, post your CYA numbers, FC/CC/TC numbers and as you know, there will be lots of great advice. Have you acquired a good test kit with FAS-DPD testing yet? This is precisely where they are worth their weight in gold.

Dave
 
OP
OP
A

andysutt

Well-known member
Jun 8, 2007
88
Arkansas
#3
Last time i checked my CYA i thin it was in the 30 to 50 ppm but I forget...

I dont know if I have enough to retest the CYA in this kit however.

I forget what all my test does but its a 6 way test.

I can only vacume into my filter but then i change it.

Been stirring it up w/ the net/pole to try and get it into the filter more when i leave it