Mustard Algae (I think) on pool floor despite high FC

Meat Friday

New member
Jun 9, 2022
2
Dallas, TX
Fiberglass pool with
FC 16.5
CC <0.5
CYA 40
Ph 7.6 CC

Chlorine level seems to be holding yet there is light brown greenish algae on the bottom of the pool in corners etc. There is also the white/gray "dust" that I assume is dead algae. No algae is growing on the walls (which I had last time I had an algae problem). The water is crystal clear.

Is it likely that what I am seeing is just dead algae?

New first time pool owner.

I have learned a ton from this forum. Thanks!
 

reggiehammond

Gold Supporter
Oct 4, 2020
706
Fort Worth, Texas
Pool Size
30000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-60 Plus
Are you using one of the recommended test kits?

Are you following the SLAM process? I assume you're trying as your FC levels are around the mark according to FC/CYA chart.

If you're brushing, dosing FC to stay at SLAM levels, and seeing dead algae, it will take some time for your filter to catch it all.
 

Meat Friday

New member
Jun 9, 2022
2
Dallas, TX
Yes, those numbers are from my tests with my Taylor K-2006. The FC doesn't seem to be dropping much. I will try the overnight test. I was just curious if it is normal for algae to only be on the bottom and for the water to be clear. I was wondering if maybe that is a sign that the algae is likely dead. The one time my algae got out of control the water was cloudy for days and the algae was all up the walls of the pool. Thanks for your help.
 

reggiehammond

Gold Supporter
Oct 4, 2020
706
Fort Worth, Texas
Pool Size
30000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-60 Plus
Yes, those numbers are from my tests with my Taylor K-2006. The FC doesn't seem to be dropping much. I will try the overnight test. I was just curious if it is normal for algae to only be on the bottom and for the water to be clear. I was wondering if maybe that is a sign that the algae is likely dead. The one time my algae got out of control the water was cloudy for days and the algae was all up the walls of the pool. Thanks for your help.
Somewhat normal to see dead algae, especially when the problem was not bad to start.
 
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread