Mechanical shaft seal won't fit, help please(with pics)

calstar

Well-known member
Feb 28, 2014
90
santa barbara, california
Replacing bearings(started getting very loud) and seals on a 14yr old Hayward Maxflo(I replaced all the seals about 7 yrs ago but not the bearings, everything went pretty smoothly until I tried to install the shaft seal(not the ceramic half) on the impeller, the interior diameter of the seal is .760, the diameter on the impeller is .800, no amount of pushing will get it on, I tried to use my press but backed off when it wouldn't come close going on. Pics of the motor spec, the kit for this is a go kit 1 which I'm using. Any help appreciated, dont know if I need another impeller or if I got a bad part in the kit, go kit 1 is hard to find, leslie doesnt even have it listed in their catalog, had to order online and it took 10 days.

Unfortunately as of today my pool is without a pump and wont have one until I get this one fixed. If I have to order a part what is the best way to maintain my pool for the time it takes the part to arrive?

thanks, Brian




diameter .800


interior diameter .760, not a press fit, also wasnt paying attention when I took this part out of the packing and I don;t know if I need to use the rubber washer or where it goes.


 
Last edited: