Maxi Therm not heating correctly.

Colatech

New member
Jul 3, 2020
1
Marianna,Florida
Just replaced our 14 year old heater with exact but new Maxi Therm 333LP. Heater lights perfectly, but burner sounds a bit muffled and it seems the water coming out is not near as warm as old one (before core went south). Reading the troubleshooting ,it says to check gas pressure or replace orifice. I try to do everything myself and have a mechanical background. any suggestions? Cant see why regulators would need to be different with same model. Thanks in advance!
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
24,583
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
Welcome to TFP.

What color is the flame burning? Blue? Yellow? Orange?

You check that these is no gas leak? We had one member who was not getting full heat output because he had a small gas leak in his pipe and was losing some of the gas outside the heater.

@swamprat69 @Pool Clown @1poolman1 ideas?
 

JamesW

TFP Expert
Mar 2, 2011
23,829
Heater lights perfectly, but burner sounds a bit muffled and it seems the water coming out is not near as warm as old one (before core went south).
That's a very subjective judgment.

The temperature rise depends on the water flow.

Do you know the water flow rate and the temperature rise from inlet to outlet?

Check the stack flue temperature by pressing and holding the Pool or Spa button (whichever is on) until the stack temperature is displayed.

Monitor the amount of gas used in one hour by checking the gas meter.
 
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.