MasterTemp won't start heating + PS light and bad LED

thrillho

New member
Jul 29, 2020
1
OC, CA
I've been impressed with the quality of the discussion here, and want to get your thoughts on my heater situation. Thanks in advance!

I have an older MasterTemp 400 NA (date looks to be, 03/27/07 (this is on the serial number sticker, which also has printed on it "MN4 03/27/07 230") The other text is faded-out). This was here when I moved-in. Heater worked fine when I wanted it. I don't remember if the Heater LED on the display worked.

A year or two ago, the display LED stopped showing all the digits and only the right-most could be seen. However, even that was missing some of the 'legs' that make up numbers. This was bothersome, but I knew the temp set point was always high enough to kick on the heater when I pressed Pool On. So, it wasn't a dealbreaker. The green LED on Pool on and Spa on work.

About a month ago, the heater would not turn on. The green LED was on, and the display looked like it always did (i.e., nearly dead). But, it wouldn't turn the burner or fan on. Then, I tried a few days later, and the heater did turn on.

A few more times it happened where it didn't work, and then a day when it did work. But now, for the last 3 weeks, the heater never starts despite the green LED being on and no other LEDs on (meaning, there are no warning LEDs on the display).

One note for you all, I never noticed the boot sequence of numbers. I just remember pressing pool on, and maybe the set point was displayed and then very quickly the current temp, or it would immediately just go to the current temp.

This past weekend, I tried to diagnose the system some more by looking at the control board. I saw that the PS LED is on when I turn Pool On. No other LEDs were on.

I checked the resistance of the pressure switch at the terminal on the control board, and it was about 10 Ohms with the pump on. Later, I checked the resistance on the pressure switch terminals. With the water flow off, the resistance was high, and with the water on, the resistance was about 2-3 Ohms. I assume these readings indicate the switch is not the problem.

To try more, took off the white connector with the 8 pins in it (the connector closest to the PS LED.) I shorted the PS posts on the board. Doing so turned off the PS LED. But immediately the LED 11 (service heater) turned on. Then, when while keeping the first pair shorted, I shorted the next two posts to one another, LED11 stayed on and now AFS turned on. Short the next two (the posts that are wired directly together) caused the LED11 and AFS LED to turn off and PS LED is on again. Finally, Shorting all the posts together in pairs, the PS remains the only LED on.

At some point in the touching of contacts and whatnot, I did get the system to start, but I don't know how I did it... (I thought it was just by shorting the purple wire pins / PS, but that didn't work again)

Questions:
Is the problem the control board?

Can I do anything more to eliminate any other components as the failure point?

Any other thoughts?

Thanks for reading this long post!
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
21,204
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
I would have just replaced the pressure switch.

I think you various jumping was not effective because the board did not see the proper sequence of operation.

@ps0303 @Pool Clown @swamprat69
 

Pool Clown

In The Industry
Sep 5, 2008
2,185
Silicon Valley, CA
Thoroughly check all the wiring for evidence of being chewed on, or through. Check the filter and pump to make sure that you are getting proper flow through the heater. A PS error is supposed to get you to look at the filter (to clean it) to restore good flow. Pressure switch should either have continuity, or infinite resistance. No real ohm reading is given for comparison. Loss of LED segments can be first signs of a board failure. The only way to correct this is with a board replacement. Unfortunately, this may be your whole problem, especially since you are reporting intermittent issues.