Mastertemp 400 - Heats up to about 83-85 degrees then service heater light comes on and HLS LED

pbrolsma

New member
Feb 17, 2020
2
Dallas Texas
My Mastertemp 400 fires and starts to heat up but when it reaches about 83-85 degrees the service heater comes on and not more heat and the HLS indicator light on the circuit board lights up. I have a salt water pool and had the whole manifold replaced about two years ago. I just replaced the thermal regulator, thermistor and the high limit switch but the problem still persists. It heats up to about 83-85 degrees and then the service heater light comes on. My next thought is to take the manifold off and replace the manifold bypass valve. Is there a way to test the manifold bypass valve without taking off the entire manifold? Any help would be greatly appreciated.
Thanks,
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
12,801
Northern NJ
Welcome to TFP.

From Pentair MasterTemp Heaters - Further Reading

HLS (High Limit Switch) Error

The HLS is often caused by lack of sufficient water flow through the heat exchanger. This can be due to several things:

  • Thermal regulator not opening.
  • External bypass open.
  • Internal bypass broken.
  • Pump too small or on too low rpm.
  • Clogged filter.
  • Scale in heat exchanger.
Bypass Valve

Bypass Valve

If the bypass valve is broken the heater will short cycle and make noise. If you look in the hole where the thermal regulator goes, you should be able to see the black disk. If you look in the water inlet, you should be able to see the spring.
You will have to take the manifold off to replace the Internal by-pass kit P/N 77707-0001.
Guide to replacing the bypass valve