Main drain mystery

BobFromNJ

New member
Jul 7, 2021
1
NJ
I'm thoroughly stumped. If I run off of skimmers only I have no air in the pump and no air in the returns. When I move the valve to pull from the main drains I get air in the filter and in the returns. If I try to run only main drains the filter doesn't get adequate flow. The pool loses no water so my conclusion is some sort of clog in the main drain lines.

My pool is set up to allow a return to the main drains. So, I set the valves to pull water from the skimmers only and return it to the main drains. For the first minute or so a lot of bubbles come up from the drains but then it runs perfectly with water pulling from the skimmers and returning to the main drains with no discernible air. If I then set the valves to go to the normal returns and start blending the intake to be from the skimmers and partially from the main drains it runs fine, with no air. However, after running for a little while the problem recurs.

My best guess is that there must be something in the drain line causing a clog that, when I reverse the flow, moves down the pipe but then comes back and lodges again when flow is restored to normal. Any suggestions on how to resolve this? I don't think a drain king will help because I can already clear it by returning to the main drains. Is it possible to snake the entire length? Is there something a pro can do with some sort of compressed air?

I can run the pool off of just the skimmers, obviously, but this leaves the issue of running dry if there's an issue with the skimmers or if the water level unexpectedly drops.
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
29,063
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
Welcome to TFP.

Many pools run fine without a main drain. If you have two skimmers I would not worry about the performance of your main drain.

Is your main drain a direct home run to your pool pad or does it connect to a skimmer?
 

markayash

Gold Supporter
Mar 21, 2016
3,546
Atlanta Ga
I'm thoroughly stumped. If I run off of skimmers only I have no air in the pump and no air in the returns. When I move the valve to pull from the main drains I get air in the filter and in the returns. If I try to run only main drains the filter doesn't get adequate flow. The pool loses no water so my conclusion is some sort of clog in the main drain lines.

My pool is set up to allow a return to the main drains. So, I set the valves to pull water from the skimmers only and return it to the main drains. For the first minute or so a lot of bubbles come up from the drains but then it runs perfectly with water pulling from the skimmers and returning to the main drains with no discernible air. If I then set the valves to go to the normal returns and start blending the intake to be from the skimmers and partially from the main drains it runs fine, with no air. However, after running for a little while the problem recurs.

My best guess is that there must be something in the drain line causing a clog that, when I reverse the flow, moves down the pipe but then comes back and lodges again when flow is restored to normal. Any suggestions on how to resolve this? I don't think a drain king will help because I can already clear it by returning to the main drains. Is it possible to snake the entire length? Is there something a pro can do with some sort of compressed air?

I can run the pool off of just the skimmers, obviously, but this leaves the issue of running dry if there's an issue with the skimmers or if the water level unexpectedly drops.
I had a clog in a spa return and reversed my plumbing and let it blow back and it pushed out a bunch of trash then finally a piece of plaster. After my comfort level went up some I let it run backwards for 30 seconds.
 
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread