Low Pressure in Pump Housing Strainer Basket

emiliasmith

New member
May 12, 2021
2
Virginia beach
Pool Size
22000
Surface
Vinyl
Chlorine
Liquid Chlorine
I will start off by saying i am new to the world of pool pumps and issues, so i may not use the correct wording. This issue is on my parents pool but i am an engineer so i am semi-capable with fixing issues.

The pool was opened after being closed all winter. Everything was working ok and then we vacuumed the pool and it has not really worked since then. We have a Doheny's self priming pool pump that was replaced last year and a Pentair DE filter. When put in the recirculation mode the water comes in from the skimmer into the strainer basket on the pump, but never reaches the top and bubbles can be seen. Water comes out of the return lines slowly and with bubbles.

When put in filter mode, water does not fill up the filter and very little pressure (1-2psi) can be seen.

items done to try and fix the issue:
  • spider gasket on the filter valve was replaced
  • drain king was purchased and used on the intake line from skimmer to strainer basket. no blockage was found
    • when a hose was put into the line the water was able to fill up the strainer basket more- however air bubbles still seen coming out of the return line
  • since issue is seen on recirculation too- i would guess it is not an issue with the filter
  • housing top for strainer basket does not appear to have any leaks or cracks. relubed the o-ring recently
    • ran water over the top and it did not fill the basket any more than was previously in there
I am at a loss and could really use help to solve the problem!
 

Texas Splash

Mod Squad
TFP Expert
LifeTime Supporter
Jun 22, 2014
32,976
Texas, San Antonio/Marion, South-Central Area
Pool Size
17888
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-45 Plus
Welcome to TFP! :wave: One thing I would try ..... push water backwards with the Drain King from the pump inlet back to the skimmer. You may have an acorn or something jammed-up enough to slow water flow and it won't move to the pump, but may jar loose the other way. You may have to try it a couple times back & forth.
 

mrbookmanlibrarycop

Well-known member
Aug 30, 2019
79
Westchester, NY
Pool Size
22000
Surface
Plaster
Chlorine
Liquid Chlorine
You might have something stuck in your pump impeller, after vacuuming something could have gotten stuck in there.

Turn the pump off at the breaker, take out the strainer basket and can fiddle around into the pump with a clothing hanger or stick and see if anything comes out. I usually stick a finger or 2 in and see if i can feel anything. Here is the video where I learned how to do it

I actually JUST did this since my filter gauge was a couple PSI below normal pressure. Had some leaves and debris in there, cleaned it out, and back to normal(y)
 
  • Like
Reactions: Texas Splash

emiliasmith

New member
May 12, 2021
2
Virginia beach
Pool Size
22000
Surface
Vinyl
Chlorine
Liquid Chlorine
As a side note update. I was able to turn the valve to filter and build up enough water/pressure to have it come out the top. After ten minutes of leaving it on filter I came back and pressure had dropped back to close to zero and the was no water coming out the top when I opened the air valve.
 

Texas Splash

Mod Squad
TFP Expert
LifeTime Supporter
Jun 22, 2014
32,976
Texas, San Antonio/Marion, South-Central Area
Pool Size
17888
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-45 Plus
Emili, your last post has me a bit confused so I better ask to clarify:
- When you say turned valve to filter to build up enough pressure to the top, I suspect you mean that with the multiport valve on filter, pressure builds and you get air to come out of a relief vent right? That would make sense.
- Then after about 10 minutes the pressure fell to zero and no more air relief at the top?
- Is the pump basket staying fully primed with water under the clear lid?

Now would be a good time to update your signature with all of your pool and equipment info. I would also suggest posting a pic of your equipment pad so we can see what you have.

Did you try both items recommended above? - Pushing water backwards and checking the impeller?
 
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.