Leak in Triton II sand filter

eemueller

LifeTime Supporter
May 31, 2013
45
SE Michigan
I have water leaking from the bottom of my sand filter. I have replaced the o-rings on the slide valve, and when I replaced the sand, the laterals looked fine. The leak was there before I replaced the sand. It is not leaking from the drain plug. Anything else to check before I have to open it up, again?
 

duraleigh

Admin
Mod Squad
TFP Expert
Platinum Supporter
LifeTime Supporter
In The Industry
Apr 1, 2007
34,358
Sebring, Florida
That Triton filter can only leak from the drain plug, right? (There are no other openings on the bottom, I think).

So, it seems the drain plug IS leaking or there is a hole in the pressure vessel which should be pretty findable.
 

eemueller

LifeTime Supporter
May 31, 2013
45
SE Michigan
That Triton filter can only leak from the drain plug, right? (There are no other openings on the bottom, I think).

So, it seems the drain plug IS leaking or there is a hole in the pressure vessel which should be pretty findable.
The leak is coming from underneath, but the tank sits on a solid pedestal, so I can't see underneath. I can see for certain that it's not the drain plug, so I guess there is a hole. Are these repairable, or do I have to replace it?
 

duraleigh

Admin
Mod Squad
TFP Expert
Platinum Supporter
LifeTime Supporter
In The Industry
Apr 1, 2007
34,358
Sebring, Florida
Despite what others may tell you, don't try to repair the pressure vessel of your filter......it will likely fail and is fairly dangerous.

Others have had some success with a warranty claim......it's worth looking into.