Jandy Stealth high pitch noise when starting up.

jjjedlic

Member
May 5, 2014
10
oklahoma
I have an 8 year old Jandy Stealth pump with an AO Smith Motor. When it starts up in the morning it makes a loud high pitched noise most days. This started about 2 weeks ago. If I shut it down and clean out the pump basket sometimes the noise will stop. Seems like it might be a bearing, but maybe could also have something to do with the impeller. I'm pretty handy, but this is not my area of expertise. Any help you can provide diagnosing the issue would be great. It doesn't look like replacement is too tough if I know what I should be replacing. Thanks very much! John
 

Rossterman

Well-known member
Jun 5, 2016
242
Martinez, CA
Probably bad bearings. You can rebuild the motor by replacing the bearings pretty cheaply. Since you will have to disassemble the wet end to do it, you probably should replace the seal and pump body o-ring gasket while you have it apart. There are some diy videos on the web if you are mechanically inclined.
 

jjjedlic

Member
May 5, 2014
10
oklahoma
In the middle of rebuild. Other than a nasty stuck corroded screw on the bell housing of the motor pretty straight forward. BUT. On the 2HP CENTURY/AOSMITH motor (part 193994) I broke a plastic piece while dealing with that nasty screw. Its a the piece attached to the back of the front bell I can't find anyplace that could sell me this piece. Somebody please help. Where can I source this? Can't imagine buying a new motor just because of this piece of flimsy plastic!


Pool Plastic.jpg.
 

Other Threads of Interest