Jandy Neverlube Valve Squeaks / Squeaking

jonpcar

Bronze Supporter
Jun 1, 2016
545
Gilbert, AZ
I have some work to do on the actuators for my Jandy 3-way Neverlube valves and so wanted to possibly address another issue when I do that: Sometime a couple years ago, I noticed that my two Jandy valves squeak when they are turned by the actuator in one direction (and only in that one direction). I think it sounds internal to the valve...is this normal?

I have had the valves installed for about 5+ years so I don't know if this squeaking has always existed. There are no leaks on the valves to my knowledge: either internal or external. So should I just continue to ignore this issue until something is more noticeable? The squeaking doesn't seem to have changed at all in the time since I first noted it. Thanks!
 

jonpcar

Bronze Supporter
Jun 1, 2016
545
Gilbert, AZ
Thanks Allen, I've looked through those parts a few times and couldn't decided whether I need to replace the large "expensive" paddle or not. That seems to be one obvious culprit for making the noise, but it also could be the shaft o-rings.

When I looked at these parts previously, I realized that INYOs "Never Lube" Jandy tune-up kit comes with lube (as you also have pointed out should be used):


It makes sense...but I have never lubed mine and the shaft o-rings are an obvious candidate...

Here is what I couldn't find an answer for: Is a recommended maintenance for "Never Lube" valves to regularly (or sporadically) lube those shaft o-rings ? I guess I am assuming that the "Never Lube" descriptor applies to the PADDLE and not the o-rings.
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
19,788
Northern NJ
Here is what I couldn't find an answer for: Is a recommended maintenance for "Never Lube" valves to regularly (or sporadically) lube those shaft o-rings ? I guess I am assuming that the "Never Lube" descriptor applies to the PADDLE and not the o-rings.
I think NEVER LUBE means that. But an O ring can tear and then need replacement.
 

jonpcar

Bronze Supporter
Jun 1, 2016
545
Gilbert, AZ
I looked around a bit and concluded you are right...nothing I could find anywhere about lubing the O-rings of a NEVER LUBE valve. Thanks for the help.