Jandy JXI 400 Not Igniting - Check IGN Seq

Cluckr7

Well-known member
Jun 19, 2020
89
Texas
Pool Size
20000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Jandy Aquapure 1400
My Jandy Jxi 400 NG heater wouldn’t ignite this weekend. It’s only 3-4 months old and I just used it multiple times last week.

This weekend, when I tried starting it up, the air blower turned on, then after several seconds I smelled NG for a few seconds, after which I heard a click and a soft gas sound, which I believe is the gas valve closing. This repeated three times until the heater shuts down with a Check IGN Seq fault. The Fenwal led blinks three times indicating a soft ignition lockout.

Wires look fine to me.

Looking through the top sight glass, at no point do I see any orange glow.

Am I correct in thinking this is a broken igniter? It is still under warranty so will get a tech out. Haven’t touched anything myself besides taking the panel off to look thru the sight glass.

See link to video here:


@setsailsoon
 

PoolGate

Gold Supporter
TFP Guide
Jun 7, 2017
5,565
Damascus, MD
Pool Size
29000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Jandy Aquapure 1400
It is the ignitor and they are very easy to replace I've done it on mine. My original ignitor lasted only 1 season but since replacement has gone 3 more.
 

Cluckr7

Well-known member
Jun 19, 2020
89
Texas
Pool Size
20000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Jandy Aquapure 1400
Thanks as always @PoolGate. Hopefully the Jandy tech can get it fixed quick and has the part on hand.

I must say, I’m not super impressed with Jandy so far. I’ve had a quirky Aqualink PDA issue where my pump didn’t turn on as schedule (which self resolved with a reset of the program), an actuator that didn’t turn for a while (which self resolved with no known change), and now this heater issue, all within the first 4 months.

I am learning a lot about my equipment though :)