Jandy High Limit Fault - 3 years in a row

Easto

Well-known member
Jun 27, 2010
167
I’m in Canada and opened the pool yesterday.

Heater was installed in 2010.

Jandy LXi

The last three years when I’ve opened the pool I’ve had to replace the limit sensors.

Can anyone suggest any reason why?
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
38,860
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
You have pics of what the sensors looked like when removed?

What indications did you have that the sensors needed replacement?
 

Easto

Well-known member
Jun 27, 2010
167
The one sensor has a white residue on it.

I just plugged in a fresh set and the heater fires up no problem.

What’s this white stuff?

If I brush it off do you suppose I can reuse these ones?
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
38,860
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
Which sensors are they?

Did you check the sensor continuity with a multimeter?

White stuff is probably some calcium scale.
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
38,860
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
Hard to guess what is going on with the sensors without testing them using a multimeter and putting them in some heated water and seeing when they open and close.
 
  • Like
Reactions: Easto
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread